none
Bug during html rendering RRS feed

  • Question

  • Hi, everybody!

    I use ReportViewer web control with 'Remote' ProcessingMode.

    Report definition (RDL file) is loaded dynamically by ReportViewer.ServerReport.LoadReportDefinition() method.

    Everything works ok, except some cases. For some RDLs a strange set of symbols appears at the header of report.

     

    Sorry, but I didn't find any better way to show you the picture of bug. You can find screen-shot here: http://rapidshare.com/files/39286813/Bug_In_Huge.JPG.

     

    I took a look into source of the page and found this:

    Code Snippet

    <DIV style="BORDER-TOP: black 1px solid; WIDTH: 800px">
    .A842b730df9484498b226756053f51b071{border:1pt SolidBlack;background-color:Transparent;background-repeat:Repeat;padding-left:0pt;padding-top:0pt;padding-right:0pt;padding-bottom:0pt;}
    <DIV id=Pa497fe8b47eb44928dda5c8b98b8277doReportDiv onresize=A842b730df9484498b226756053f51b07ShowFixedHeaders() style="OVERFLOW: auto; WIDTH: 100%; HEIGHT: 100%" onscroll=A842b730df9484498b226756053f51b07ShowFixedHeaders()>

     

    Any ideas what it can be?

    Thank you.

     

    Configuration:

    • Microsoft Windows Server 2003 Enterprise Edition Service Pack 1
    • Microsoft SQL Server 2005 SP2
      • Microsoft SQL Server Reporting Services 9.00.3042.00
    • Microsoft Visual Studio 2005 Team Edition for Architects
    • Framework 2.0
    • IIS 6.0
    Monday, June 25, 2007 4:43 PM

All replies

  • Hello Everyone..

    Any updates on the above mentioned issue??...I am also experiencing the same problem with my reports...
    Thursday, July 24, 2008 1:44 PM
  • hmmmm, your using load report definition.... what's the original format of the file? Is it stored somewhere as a byte array?

    I ask because if it's not converted correctly, some special characters can come out wrong.
    Living my life at 123mph in 11.15 seconds
    Thursday, July 24, 2008 5:10 PM