none
OneDrive for Business uses high CPU since Office 365 1712 8827.2148

    Question

  • Hello everyone

    The OneDrive Support told me that this is not their problem and I should ask here for advice.

    We are using SharePoint on Premise and therefore must use OneDrive for Business (Groove.exe) to sync our userdata with SharePoint.
    Now, since the Office 365 Update 1712 (Build 8827.2148) our OneDrive for Business permanently uses one CPU core at 100%.
    No permanent network traffic, no errors. Sync is working perfectly fine, just high CPU usage.

    Problem affects every computer (approximately 100) that got the update. Repairing and reinstallation of Office and OneDrive did not help.
    Also I was told to delete the local OneDrive cache which also had no impact.

    Does anyone else have this problem or may even knows a solution?!

    Thanks a lot!

    Andy

    Update 07.02.2018: The recent Office 365 Update 1801 (Build 9001.2138) did not resolve this issue.
    Update 19.02.2018: The recent Office 365 Update 1801 (Build 9001.2171) did not resolve this issue.
    Update 27.02.2018: The recent Office 365 Update 1802 (Build 9029.2167) did not resolve this issue.
    Update 14.03.2018: The recent Office 365 Update 1802 (Build 9029.2253) did not resolve this issue.

    UPDATE 03.04.2018: The Office 365 Update 1803 (Build 9126.2116) seems to have finally FIXED this issue! More about this in the marked answer.

    Monday, January 29, 2018 2:42 PM

Answers

  • It looks like this issue should be fixed in Version 1803 (Build 9126.2098) per https://technet.microsoft.com/en-us/office/mt465751.aspx.  Currently this version appears to be available for the Monthly Channel (Targeted) and Semi-Annual Channel (Targeted).

    I do not have access to Version 1803 yet.

    OneDrive for Business: Non-security updates

    This channel release contains the following non-security updates:

    • Fix an issue where OneDrive for Business (Groove.exe) consumes one CPU core’s worth of CPU (for example, 25% on a 4 core CPU) in Task Manager for extended periods of time.

    Tuesday, March 27, 2018 2:14 PM
  • Just got 1803 on my Technet install of Office 2016. GROOVE.EXE is version 16.0.9126.2116. Opened a ~150k Excel file, edited it, saved it, watched the OneDrive for Business icon do the sync animation, stop, and then say everything is up to date. Saw the icon on the file I was working on go from a sync icon to a green check. 

    GROOVE.EXE is sitting at 0% CPU ~5 minutes later.

    Is it fixed? Is it really fixed? No April Fool's? 


    Monday, April 02, 2018 7:14 PM
  • The recent Office 365 Update 1803 (Build 9126.2116) of the monthly Update Channel seems to now finally have fixed this issue! So far I have not been able to reprodce the high CPU-Usage after installing this update.

    The only thing that bothers me is that we did not yet get any update on our support ticket from Microsoft. Probably will have to wait another two months on that... at least the problem Looks to be solved now!

    Tuesday, April 03, 2018 6:21 AM

All replies

  • Hi,

    I have encountered exactly the same problem since updating My Office today. Would very much appreciate any help in resolving this.

    Kalle

    Monday, January 29, 2018 5:49 PM
  • Hi,

    I have the same problem after installing the latest Office update.

    I tried all the 'normal' fixes but it is still the same. When I restart my computer i looks fine, but if I go to the filepath where my files are located, using Windows Explorer, the CPU goes up to around 32% and stays there.

    /Peter

    Tuesday, January 30, 2018 2:28 PM
  • Hi,

    Same problem since newest version :(

    - I have cleaned cache, as suggested on another MS forum.

    - Re-synced all shares from SharePoint.

    And still 12% CPU (this is 100%CPU of one of my cores):

    @MS: Any plan to fix it? 

    /Marcin

    p.s. We can disable heating in our office as all PCs fans are working almost all time now :P xD

    Wednesday, January 31, 2018 9:52 AM
  • Same problem here, in my organization I have 400 pcs. All updated pcs to office 1712 have this issue.
    Wednesday, January 31, 2018 2:55 PM
  • Same thing with Version 1801 (Build 9001.2122 Click-to-Run) and SharePoint Server 2013

    John

    Wednesday, January 31, 2018 3:56 PM
  • We are having the same issue here as well, same problem and same environment. Luckily we are in transition to 365 and only have a couple dozen laptop with this issue. Microsoft needs to address this.
    Wednesday, January 31, 2018 6:50 PM
  • Hi,

    According to your description, it seems that it is cased by this update.

    You can use the dump file to narrow down this issue.

    By the way, this issue is difficult to solve through the forums to help you.

    I suggest you open a ticket from Microsoft, this will help you to solve the issue as soon as possible.

    Thanks for understanding.

    Best Regards,

    Carl Zhou


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Thursday, February 01, 2018 6:07 AM
  • We have exactly the same issue here! Sharepoint 2013 Server (on Premise) und Office 365 (One Drive for Business).

    When can we expect a fix? 

    Thursday, February 01, 2018 7:30 AM
  • Hi,

    I'd love to make a ticket for this issue, yet my company does not have the budget for that sadly.

    It is also weird that there are so many people now with this problem and Microsoft still does not seem to want to act on their own.

    Thursday, February 01, 2018 9:12 AM
  • I suffer from high CPU usage as well.  WHat I noticed is that if I pause the syncing.  Stop the client and restart it, the client remains low in CPU utilization.  But as soon as I resume syncing, the CPU usage gets pegged.

    This is especially frustrating as I am using a Surface Pro that is having issues with CPU throttling and Fans (it shuts off / standby if I don't kill the process soon enough).

    Thursday, February 01, 2018 2:10 PM
  • I have the same exact issue on a Lenovo laptop and a Surface Pro 4, both are running Office 2016 Click-to-Run version 1712 (build 8827.2148 Click-to-Run).  Groove.exe consumes around 40% CPU on a dual-core i7 Surface Pro 4 and about 20% CPU on a quad-core i7 Lenovo laptop, causing the fans to run much more than normal due to the overall higher CPU usage.

    My OneDrive for Business (Groove) client is connected to my OneDrive for Business personal storage in an on-premise SharePoint 2013 server.

    I have disconnected the library, deleted the local cache, rebooted and then re-connected the client to my OneDrive for Business library in our on-premise SharePoint 2013 server and the high CPU usage issue still persists.




    • Edited by mike.driest Friday, February 02, 2018 6:35 PM Updated CPU usage
    Thursday, February 01, 2018 3:42 PM
  • Same issues with 1712 (Build 8827.2179) x64 - I just updated, One Drive for Business is using approx 30% CPU for no reason - MS where is the fix?

    Thursday, February 01, 2018 10:18 PM
  • Same issue, around 30% CPU, (1 core 100%). Really really annoying. I'm continuously shutting down the sync client as a workaround but it's not practical.
    Friday, February 02, 2018 9:08 AM
  • Hi Carl,

    Our IT made Ticket.
    What troubles me is that as you may see this is global problem, maybe you can escalate this issue higher or provide us with link where we can track problem?

    /Marcin

    Friday, February 02, 2018 10:38 AM
  • Thank you very much Marcin! You're a lifesaver!

    Let's hope that the issue will be found quickly and already resolved in the next update cycle. (But that might be a bit too late already sadly.)

    Friday, February 02, 2018 10:46 AM
  • Just adding my voice to everyone else's. Since the latest update, OneDrive for Business hovers around 31% CPU usage. My current approach is to shut it down most of the time turning it on once or twice a day to bring my synchronization up to date.

    I hope Microsoft gets the message and fixes this one quickly!

    Saturday, February 03, 2018 6:00 AM
  • Hi,

    I have the same problem after installing the latest Office update!!!

    Saturday, February 03, 2018 3:31 PM
  • I have this same issue. But what I don't get is that even when I close the application with Task Manager, it starts running automatically again after a few minutes. I have to keep terminating it manually. I also can't see an option to prevent OneDrive for Business from running at startup.
    Sunday, February 04, 2018 8:50 AM
  • Same here - Onedrive for business, version 16.0.8431.2153

    I've renamed groove.exe to something else in here and it stops it's respawning.

    C:\Program Files (x86)\Microsoft Office\root\Office16\


    Eliot

    Sunday, February 04, 2018 11:08 AM
  • Hi,

    Got reply from Support, but it seems that Microsoft Support is focusing on onedrive.exe not on groove.exe.

    Nevertheless this is what they wrote:

    ISSUE
    High CPU usage is observed, after OneDrive for business update.  

    SCOPE
    The case is going to be considered as resolved, one the high CPU utilization is not present. In addition, the case is considered solved and can be archived, if we establish that the problem is 3rd party software/hardware problem, bug or behavior by design.  

    FINDINGS
    Please follow the suggested action plan below:

    1. Open Task Manager, right-click the Microsoft OneDrive process and select End Task. Restart OneDrive and see if this helps.

    2. Rest the one drive application and see if that works. https://answers.microsoft.com/en-us/onedrive/forum/odstart-oduninstall/full-reset-of-onedrive-on-windows-10/12a357f8-7773-4856-bf0c-0ecd308f4184?auth=1

    3. If the above does not help, exit OneDrive and navigate to the following location in File Explorer: %AppData%\Local\Microsoft\OneDrive\setup\logs Locate the following two hidden files and delete them. a. UserTelemetryCache.otc b. UserTelemetryCache.otc.session Now restart OneDrive and see if it helps.

    4. If nothing helps, you may have to uninstall OneDrive completely and reinstall it again.

    UPDATE:
    Fix provided from Support does not fix the problem.


    Tuesday, February 06, 2018 8:13 AM
  • Adding myself to the list. Exactly the same problem here.

    MICROSOFT: How about a fix??

    Tuesday, February 06, 2018 10:43 AM
  • Add me and my organization to this list as well. I have been researching this for a few weeks now and tried the below steps with no luck.  Comes right back. CPU between 20% and 50% and the only way i really noticed was because it gets my Surface Book fans going which hardly ever run. 

    1. Open Task Manager, right-click the Microsoft OneDrive process and select End Task. Restart OneDrive and see if this helps.

    2. Rest the one drive application and see if that works. https://answers.microsoft.com/en-us/onedrive/forum/odstart-oduninstall/full-reset-of-onedrive-on-windows-10/12a357f8-7773-4856-bf0c-0ecd308f4184?auth=1

    3. If the above does not help, exit OneDrive and navigate to the following location in File Explorer: %AppData%\Local\Microsoft\OneDrive\setup\logs Locate the following two hidden files and delete them. a. UserTelemetryCache.otc b. UserTelemetryCache.otc.session Now restart OneDrive and see if it helps.

    4. If nothing helps, you may have to uninstall OneDrive completely and reinstall it again.

    Tuesday, February 06, 2018 2:56 PM
  • That "Action Plan" is exactly what I meant in my innitial post with "Also I was told to delete the local OneDrive cache which also had no impact."

    So basically, back to step one.

    Microsoft, please listen. There is an error here that various multiple companies are expiriencing and we need your help.

    Tuesday, February 06, 2018 3:43 PM
  • Added it to the top too but just in case someone checks the last messages first:

    The recent Office 365 Update 1801 (Build 9001.2138) did not resolve this issue. It perists.

    Wednesday, February 07, 2018 9:06 AM
  • I have the same issue with Office 365 1801 (Build 9001.2138) and no fix till now.

    Wednesday, February 07, 2018 12:37 PM
  • Also on v 1801 and seeing this same issue. It has begun to effect more users throughout our ORG as well. 
    Wednesday, February 07, 2018 5:17 PM
  • On my two Win 10 Pro x64 devices I am running 2016 x86 Version 1801 (Build 9001.2138 Click-to-Run) with Groove.exe still constantly using the CPU.
    Wednesday, February 07, 2018 6:54 PM
  • I concur. Built 9001.2138 doesn't work.

    Like everybody, I had to stop OneDrive for Business entirely and have to rely on browser access for now, which is certainly not ideal.

    I look forward to a fix.

    Wednesday, February 07, 2018 7:46 PM
  • I have the same issue with Office 365 1801 (Build 9001.2138) and no fix till now.

    Same issue here using 1801 Build 9001.2138 too. Tried to get detailed information what causes this issue using process monitor but found nothing helpful. Waiting for fix.
    Thursday, February 08, 2018 6:42 AM
  • Exact the same problem with the same versions as mentioned above. None of the mentionend things helped.
    • Edited by Helge Hoehn Thursday, February 08, 2018 10:18 PM
    Thursday, February 08, 2018 10:18 PM
  • Same here again with consist around 31% usage. It's so annoying and slow down my whole comp.

    

    


    MCSD .NET, SCJP, SCJWD

    Thursday, February 08, 2018 11:35 PM
  • Hate to say 'me too'.....but me too. Been this way for a month or so now. 

    Does it on my Dell Latitude 7480 on Windows 10 1709 RTM (25% CPU on a Core i5) and on my Surface 4 Pro on Windows 10 17093 (25% CPU on a Core i5). 

    Syncing to an on-premises Sharepoint 2013 library. 

    Fan noise is driving me nuts. 


    Friday, February 09, 2018 12:52 AM
  • Exact same issue here, observed on two separate machines. Version 1801 (Build 9001.2144) is still broken, and yes it has been going on for about a month.

    Deleting UserTelemetryCache.otc and UserTelemetryCache.otc.session did NOT work.

    Depending on the machine it is pegged at 20-30% CPU doing nothing.

    I hope Microsoft are listing because constantly exiting the OneDrive app every time I open Office is driving me nuts too.


    • Edited by eforgacs Friday, February 09, 2018 6:48 AM
    Friday, February 09, 2018 6:46 AM
  • #MeToo
    Friday, February 09, 2018 7:37 AM
  • HAHAHAHA, Microsoft address a problem.  I hope you're not holding your breath.  They're as pig headed as our government.

    Helpful nice guy

    Friday, February 09, 2018 8:48 AM
  • The answer he gave you is normal IT answer.  Create a ticket and we'll take care of it.  Yeah right.  More like "Wait until someone finds something they can exploit, they'll create a virus that takes advantage of it then Microsoft will do something about it."  Oh wait, that doesn't always work.  File extensions are still hidden by default but yet viruses take advantage of the hidden extensions every day.

    Sorry if I sound sarcastic but I've been in IT for over 20 years and it never changes.  Companies think they're never wrong.


    Helpful nice guy

    Friday, February 09, 2018 8:52 AM
  • Exactly the same issue here.  Brand new high spec laptop, was working great then I applied the updates!

    Version 1801.

    :(

    Friday, February 09, 2018 10:00 AM
  • Seems as if i did solve my problem here:

    Stopped synching, and with that i did cut the connection of that pc with online.

    Stopped OneDrive for Business (right mouseclick - exit).

    Restartet Windows, deleted the old local synch-folder, then i went online with browser to the onedrive and did hit "Synch"-Symbol from there. This started Onedrive for Business again, asked for password, i then changed the local folder to something else (as i always do), and started synching.

    All fine now.

    The difference is that i did not supply the adress to be synched within the onedrive-tool, but i passed that piece of information by hitting "Synch" in the online-view.

    Give it a try, i can't tell you why that helped.

    • Proposed as answer by trlbb Sunday, February 11, 2018 10:57 AM
    • Unproposed as answer by Miingno aka. Andy Thursday, February 15, 2018 9:10 AM
    Saturday, February 10, 2018 2:55 PM
  • Brilliant, thank you so much!

    I followed your instructions to the letter except for the reboot part, which I skipped. What this seems to do is force migration from GROOVE.EXE to OneDrive.exe which now handles both OneDrive personal and OneDrive for Business.

    Note: based on my scientific observation of a representative sample of 2 PCs ;-), the groove.exe problem seems to only occur in Windows FCU, because I never experienced it on my Work PC which is running a less recent release of Win10.

    • Edited by trlbb Sunday, February 11, 2018 3:07 PM
    Sunday, February 11, 2018 11:03 AM
  • I think you are right with the migration thing... as i recognized after that trick, that at every reboot a popup occured asking me to specify a library to synch with... although in the taskbar i could see Onedrive already activ, and status "All synched". Then, after some while, i detected that i had two cloudsymbols running, the activ one, and the second one starting with windows and asking for a hyperlink to a library. I disabled that one with deselecting "Start with Windows Boot", and then it was gone. So... somehow to instances of onedrive arround here ;-)
    Sunday, February 11, 2018 11:20 AM
  • I've been frustrated with the same problem, but problem solved with the help of the comments in this forum.

    Step 3 of @Outlanderbz's solution worked for me, with the extra step that @NoPlayback suggested.

    1. I exited Onedrive for Business (right mousclick - exit),
    2. then deleted the two files in %AppData%\Local\Microsoft\OneDrive\setup\logs (a. UserTelemetryCache.otc b. UserTelemetryCache.otc.session)
    3. then restarted my computer
    4. then i went online with browser to the onedrive and hit "Sync"-Symbol from there.
    5. waited for password prompt to come up (it took about 2 minutes before it popped up), entered password, and all seems fine now.
    Sunday, February 11, 2018 3:44 PM
  • Although this cannto work for on premise stuff I tried and failed. There is no migration to OneDrive for on premise Sharepoint. As a hint: If I stop GROOVE.exe and make sure that there is no explorer window "sitting" on the One Drive For Business folder, then GROOVE.exe is not restarted and everything seems to be fine. As soon as I start a Windows Explorer and change to the folder GROOVE.exe appears and consumes a whole CPU/thread.

    Monday, February 12, 2018 1:47 PM
  • I've tried this and unfortunately it doesn't work for me.

    I've even downloaded the most up to date OneDrive.exe but that gives me a connection error.


    Wednesday, February 14, 2018 5:05 PM
  • Thanks NoPlayback for your suggestions here. Glad it worked for you but nothing for me. Still sitting on the CPU.
    Thursday, February 15, 2018 9:11 AM
  • It appears Microsoft is phasing out Groove.exe.

    https://support.office.com/en-us/article/changes-to-the-previous-onedrive-sync-client-groove-exe-in-office-2016-click-to-run-3eff17b9-c709-462f-946c-17719af68aca


    • Edited by Jessy_D Thursday, February 15, 2018 2:31 PM
    Thursday, February 15, 2018 2:31 PM
  • It appears Microsoft is phasing out Groove.exe.

    https://support.office.com/en-us/article/changes-to-the-previous-onedrive-sync-client-groove-exe-in-office-2016-click-to-run-3eff17b9-c709-462f-946c-17719af68aca


    Interesting that no one at Microsoft yet mentioned this here.. That's kinda a key point for this issue.

    However it means a LOT of work for companies like ours where hundreds of people are currently using Groove to sync data... Thanks MS

    Friday, February 16, 2018 7:16 AM
  • It appears Microsoft is phasing out Groove.exe.

    https://support.office.com/en-us/article/changes-to-the-previous-onedrive-sync-client-groove-exe-in-office-2016-click-to-run-3eff17b9-c709-462f-946c-17719af68aca


    Interesting that no one at Microsoft yet mentioned this here.. That's kinda a key point for this issue.

    However it means a LOT of work for companies like ours where hundreds of people are currently using Groove to sync data... Thanks MS

    So I made a test and excluded Groove.exe as suggested in the article above. Sadly now I am unable to sync with our on-premise installation as it just tells me, no suitable OneDrive for Business client is installed. And when I try to download the newest OneDrive client it simply tells me, that I already have a newer version installed.

    Should've read the fine print on the page above confirming that:

    "However, the previous OneDrive for Business sync client (Groove.exe) is still fully supported and is used for on-premises instances of OneDrive for Business or SharePoint Server"

    And with that I want Microsoft to finally fix that bug please!

    • Proposed as answer by Marcin Rudzki Tuesday, March 06, 2018 3:12 PM
    • Unproposed as answer by Marcin Rudzki Tuesday, March 06, 2018 3:12 PM
    Friday, February 16, 2018 8:03 AM
  • I found out that OneDrive for bussines is generating some logs files inside following path:

    C:\Users\username\AppData\Local\Microsoft\Office\Spw\logs

    Maybe someone can figure out how to fix it with this hint...

    Monday, February 19, 2018 6:56 AM
  • This did not help for me ... Still on 50% CPU usage.

    When I click on Sync button, I also get OneDrive has stopped working error (but the truth is, it continues running).

    Working on Windows Server 2008.

    Tuesday, February 20, 2018 9:16 AM
  • Hi All,

    I solved the problem by switching to the new OneDrive Sync client and getting rid of the old (Groove.exe) version entirely. This works for the Microsoft-hosted (Office 365) versions of OneDrive for Business and SharePoint. If you're syncing with on-premises versions then you will have to wait a few months.

    See the bottom of this post for links to helpful articles.

    First, you need to know how to tell which TaskBar icons correspond to the new and old sync clients. That's because you may have them both running while switching over. Here's a summary:

    • Icon: White Cloud, Tooltip: "OneDrive" = NEW OneDrive Personal.
    • Icon: Blue Cloud, Tooltip: "OneDrive - (your business name)" = NEW OneDrive for Business
    • Icon: Blue Cloud with white outline, Tooltip: "OneDrive for Business" = OLD OneDrive for Business

    The new OneDrive Personal and OneDrive for Business are really the same application. It just manifests two icons; one tied to each service.

    Here are the steps to switching over.

    1. Make sure you have the latest OneDrive Sync installed. If you're on Windows 10 and/or you use OneDrive Personal that's probably the case. (See the links below for details.)
    2. Run windows update and reboot your computer just to be sure everything is clean.
    3. Make sure the old OneDrive for Business is fully synced. The tooltip should say "Up to date." Resolve any sync conflicts if necessary.
    4. Right-click the old OneDrive for Business icon and select "Stop syncing a folder." If you are syncing multiple folders (e.g. with SharePoint) repeat this for every folder. When you're done the tooltip should read, "No libraries are currently connected."
    5. Delete the lingering folders that were being synced. If you did step 3 right then all of the files are backed up in the cloud. You can use the web interface to be sure. If you're being particularly careful, then rename the folders or back them up on flash media. Just don't leave them there because the new folders will take their place.
    6. Right click the NEW OneDrive Sync icon (white cloud) and select "Settings". On the "Account" tab click the "Add an Account" button. Enter your OneDrive for Business credentials. It will create new folders and sync everything back to your computer. The NEW blue cloud OneDrive for Business icon will appear on your taskbar. (See the links below for details.)
    7. See the links below for how to sync SharePoint folders on the new client.

    Assuming all of this worked for you, then all of your files are being synced with the new client and you won't have the CPU issues or other bugs that plague the old Groove.exe SharePoint Sync. Nevertheless, the old sync app is still running on your machine. I searched all over and could not find any clean way to uninstall it. According to one of the articles below, it may automatically be uninstalled by an update in August 2018.

    In the meantime, your best option is simply to disable but not uninstall the old sync client. Run "Task Manager" and select the Startup tab. Right-click "Microsoft OneDrive for Business" and select "Disable". That will keep it from automatically starting when you reboot.

    Helpful articles:

    • Which version of OneDrive am I using: https://support.office.com/en-us/article/which-version-of-onedrive-am-i-using-19246eae-8a51-490a-8d97-a645c151f2ba
    • Installing and configuring the New OneDrive Sync Application: https://support.office.com/en-us/article/sync-files-with-the-onedrive-sync-client-in-windows-615391c4-2bd3-4aae-a42a-858262e42a49?ui=en-US&rs=en-US&ad=US
    • Sync SharePoint folders using the new OneDrive Client: https://support.office.com/en-us/article/sync-sharepoint-files-with-the-new-onedrive-sync-client-6de9ede8-5b6e-4503-80b2-6190f3354a88?ui=en-US&rs=en-US&ad=US
    • SysAdmin - how to do this for your whole enterprise: https://support.office.com/en-us/article/Transition-from-the-previous-OneDrive-for-Business-Sync-Client-4100df3a-0c96-464f-b0a8-c20de34da6fa
    • Microsoft plans for future OneDrive Sync updates: https://support.office.com/en-us/article/changes-to-the-previous-onedrive-sync-client-groove-exe-in-office-2016-click-to-run-3eff17b9-c709-462f-946c-17719af68aca

    I hope this helps you all. It certainly helped me!

    • Proposed as answer by philiomanie Wednesday, February 21, 2018 2:24 PM
    • Unproposed as answer by Miingno aka. Andy Monday, February 26, 2018 11:00 AM
    • Proposed as answer by Ben Brandt Friday, March 02, 2018 4:12 PM
    • Unproposed as answer by Miingno aka. Andy Thursday, March 08, 2018 1:52 PM
    • Proposed as answer by QFA1213 Saturday, March 10, 2018 8:16 AM
    • Unproposed as answer by Miingno aka. Andy Thursday, March 15, 2018 1:54 PM
    Wednesday, February 21, 2018 4:23 AM
  • Hi All,

    I solved the problem by switching to the new OneDrive Sync client and getting rid of the old (Groove.exe) version entirely. This works for the Microsoft-hosted (Office 365) versions of OneDrive for Business and SharePoint. If you're syncing with on-premises versions then you will have to wait a few months.

    See the bottom of this post for links to helpful articles.

    First, you need to know how to tell which TaskBar icons correspond to the new and old sync clients. That's because you may have them both running while switching over. Here's a summary:

    • Icon: White Cloud, Tooltip: "OneDrive" = NEW OneDrive Personal.
    • Icon: Blue Cloud, Tooltip: "OneDrive - (your business name)" = NEW OneDrive for Business
    • Icon: Blue Cloud with white outline, Tooltip: "OneDrive for Business" = OLD OneDrive for Business

    The new OneDrive Personal and OneDrive for Business are really the same application. It just manifests two icons; one tied to each service.

    Here are the steps to switching over.

    1. Make sure you have the latest OneDrive Sync installed. If you're on Windows 10 and/or you use OneDrive Personal that's probably the case. (See the links below for details.)
    2. Run windows update and reboot your computer just to be sure everything is clean.
    3. Make sure the old OneDrive for Business is fully synced. The tooltip should say "Up to date." Resolve any sync conflicts if necessary.
    4. Right-click the old OneDrive for Business icon and select "Stop syncing a folder." If you are syncing multiple folders (e.g. with SharePoint) repeat this for every folder. When you're done the tooltip should read, "No libraries are currently connected."
    5. Delete the lingering folders that were being synced. If you did step 3 right then all of the files are backed up in the cloud. You can use the web interface to be sure. If you're being particularly careful, then rename the folders or back them up on flash media. Just don't leave them there because the new folders will take their place.
    6. Right click the NEW OneDrive Sync icon (white cloud) and select "Settings". On the "Account" tab click the "Add an Account" button. Enter your OneDrive for Business credentials. It will create new folders and sync everything back to your computer. The NEW blue cloud OneDrive for Business icon will appear on your taskbar. (See the links below for details.)
    7. See the links below for how to sync SharePoint folders on the new client.

    Assuming all of this worked for you, then all of your files are being synced with the new client and you won't have the CPU issues or other bugs that plague the old Groove.exe SharePoint Sync. Nevertheless, the old sync app is still running on your machine. I searched all over and could not find any clean way to uninstall it. According to one of the articles below, it may automatically be uninstalled by an update in August 2018.

    In the meantime, your best option is simply to disable but not uninstall the old sync client. Run "Task Manager" and select the Startup tab. Right-click "Microsoft OneDrive for Business" and select "Disable". That will keep it from automatically starting when you reboot.

    Helpful articles:

    • Which version of OneDrive am I using: https://support.office.com/en-us/article/which-version-of-onedrive-am-i-using-19246eae-8a51-490a-8d97-a645c151f2ba
    • Installing and configuring the New OneDrive Sync Application: https://support.office.com/en-us/article/sync-files-with-the-onedrive-sync-client-in-windows-615391c4-2bd3-4aae-a42a-858262e42a49?ui=en-US&rs=en-US&ad=US
    • Sync SharePoint folders using the new OneDrive Client: https://support.office.com/en-us/article/sync-sharepoint-files-with-the-new-onedrive-sync-client-6de9ede8-5b6e-4503-80b2-6190f3354a88?ui=en-US&rs=en-US&ad=US
    • SysAdmin - how to do this for your whole enterprise: https://support.office.com/en-us/article/Transition-from-the-previous-OneDrive-for-Business-Sync-Client-4100df3a-0c96-464f-b0a8-c20de34da6fa
    • Microsoft plans for future OneDrive Sync updates: https://support.office.com/en-us/article/changes-to-the-previous-onedrive-sync-client-groove-exe-in-office-2016-click-to-run-3eff17b9-c709-462f-946c-17719af68aca

    I hope this helps you all. It certainly helped me!

    Worked for me instantly!
    Wednesday, February 21, 2018 2:25 PM
  • Hi All,

    I solved the problem by switching to the new OneDrive Sync client and getting rid of the old (Groove.exe) version entirely. This works for the Microsoft-hosted (Office 365) versions of OneDrive for Business and SharePoint. If you're syncing with on-premises versions then you will have to wait a few months.

    See the bottom of this post for links to helpful articles.

    First, you need to know how to tell which TaskBar icons correspond to the new and old sync clients. That's because you may have them both running while switching over. Here's a summary:

    • Icon: White Cloud, Tooltip: "OneDrive" = NEW OneDrive Personal.
    • Icon: Blue Cloud, Tooltip: "OneDrive - (your business name)" = NEW OneDrive for Business
    • Icon: Blue Cloud with white outline, Tooltip: "OneDrive for Business" = OLD OneDrive for Business

    The new OneDrive Personal and OneDrive for Business are really the same application. It just manifests two icons; one tied to each service.

    Here are the steps to switching over.

    1. Make sure you have the latest OneDrive Sync installed. If you're on Windows 10 and/or you use OneDrive Personal that's probably the case. (See the links below for details.)
    2. Run windows update and reboot your computer just to be sure everything is clean.
    3. Make sure the old OneDrive for Business is fully synced. The tooltip should say "Up to date." Resolve any sync conflicts if necessary.
    4. Right-click the old OneDrive for Business icon and select "Stop syncing a folder." If you are syncing multiple folders (e.g. with SharePoint) repeat this for every folder. When you're done the tooltip should read, "No libraries are currently connected."
    5. Delete the lingering folders that were being synced. If you did step 3 right then all of the files are backed up in the cloud. You can use the web interface to be sure. If you're being particularly careful, then rename the folders or back them up on flash media. Just don't leave them there because the new folders will take their place.
    6. Right click the NEW OneDrive Sync icon (white cloud) and select "Settings". On the "Account" tab click the "Add an Account" button. Enter your OneDrive for Business credentials. It will create new folders and sync everything back to your computer. The NEW blue cloud OneDrive for Business icon will appear on your taskbar. (See the links below for details.)
    7. See the links below for how to sync SharePoint folders on the new client.

    Assuming all of this worked for you, then all of your files are being synced with the new client and you won't have the CPU issues or other bugs that plague the old Groove.exe SharePoint Sync. Nevertheless, the old sync app is still running on your machine. I searched all over and could not find any clean way to uninstall it. According to one of the articles below, it may automatically be uninstalled by an update in August 2018.

    In the meantime, your best option is simply to disable but not uninstall the old sync client. Run "Task Manager" and select the Startup tab. Right-click "Microsoft OneDrive for Business" and select "Disable". That will keep it from automatically starting when you reboot.

    Helpful articles:

    • Which version of OneDrive am I using: https://support.office.com/en-us/article/which-version-of-onedrive-am-i-using-19246eae-8a51-490a-8d97-a645c151f2ba
    • Installing and configuring the New OneDrive Sync Application: https://support.office.com/en-us/article/sync-files-with-the-onedrive-sync-client-in-windows-615391c4-2bd3-4aae-a42a-858262e42a49?ui=en-US&rs=en-US&ad=US
    • Sync SharePoint folders using the new OneDrive Client: https://support.office.com/en-us/article/sync-sharepoint-files-with-the-new-onedrive-sync-client-6de9ede8-5b6e-4503-80b2-6190f3354a88?ui=en-US&rs=en-US&ad=US
    • SysAdmin - how to do this for your whole enterprise: https://support.office.com/en-us/article/Transition-from-the-previous-OneDrive-for-Business-Sync-Client-4100df3a-0c96-464f-b0a8-c20de34da6fa
    • Microsoft plans for future OneDrive Sync updates: https://support.office.com/en-us/article/changes-to-the-previous-onedrive-sync-client-groove-exe-in-office-2016-click-to-run-3eff17b9-c709-462f-946c-17719af68aca

    I hope this helps you all. It certainly helped me!

    Worked for me too!
    Thursday, February 22, 2018 2:01 PM
  • Hi all,

    I have disabled the automatic start of groove.exe at startup and it seems that the process is no longer activated. Both Onedrive for Business and Onedrive Personal (and related processes) work and are updated and synchronized. Let's see what happens in the next days. My laptop fans thank and turn at normal speeds finally. I hope this can help.

    Friday, February 23, 2018 12:17 PM
  • Thank you for this summary.

    However I made that post for the on-premises version of SharePoint and about the problem we experience with groove.exe and therefore it is not a solution for me. It may help some but I'm still stuck here.

    Monday, February 26, 2018 11:03 AM
  • I'm still waiting for a fix but for now I've downgraded to Version 1711 (Build 8730.2175) and disabled updates as a workaround. If you have click-to-run version you can do it via officec2rclient.exe:

    https://support.microsoft.com/en-gb/help/2770432/how-to-revert-to-an-earlier-version-of-office-2013-or-office-2016-clic

    Or the Office Deployment Tool xml:

    <Configuration>
        <Add Version="16.0.8730.2175" OfficeClientEdition="32" Channel="Monthly">
            <Product ID="O365ProPlusRetail">
                <Language ID="en-us"/>
            </Product>
        </Add>
    </Configuration>


    Monday, February 26, 2018 1:56 PM
  • This worked for me

    1. Have OneDrive for Business Stop syncing

    2. Open Task Manager, right-click the Microsoft OneDrive process (GROOVE.EXE) and select End Task.

    3. Exit OneDrive and navigate to the following location in File Explorer: %AppData%\Local\Microsoft\OneDrive\setup\logs Locate the following two hidden files and delete them. a. UserTelemetryCache.otc b. UserTelemetryCache.otc.session Now restart OneDrive and see if it helps.

    4. Reboot the system

    This seems to have cause the groove.exe to be replace by the OneDrive.exe for some reasons and now my laptop is mouse quiet again! Yeaaahhh!


    • Edited by ekanis Thursday, March 01, 2018 9:53 AM
    Monday, February 26, 2018 4:14 PM
  • Seems to be working for me too.

    Furthermore OneDrive app enables you to select which folders to sync, which Groove.exe didn't seem to support. Much better.

    Monday, February 26, 2018 8:28 PM
  • We are using SharePoint on Premise and therefore must use OneDrive for Business (Groove.exe) to sync our userdata with SharePoint. This issue is not about the O365 version of SharePoint.
    Also the recent Office 365 Update 1802 (Build 9029.2167) did still not resolve this issue.

    We now had to submitt another ticket (as the first one was closed and only fixed the new OneDrive and not the old Groove.exe). So we are currently waiting again on Microsoft to lift their fingers and finally fix this. It's just so frustrating to have to pay for a bugfix that microsoft caused in the first place!

    Tuesday, February 27, 2018 7:20 AM
  • Yes, when I posted my solution of switching to the new OneDrive sync I knew it wouldn't solve the problem for Andy and others syncing with on-premises versions of OneDrive and SharePoint.

    The articles I read seem to indicate that Microsoft intends to support on-premises with the new solution by August (though they don't explicitly say so). If true, that's both good and bad news. Groove.exe has always been buggy for me and the new solution is more reliable. However, MS may be ignoring this contemporary bug while they invest their effort in the new solution.

    Tuesday, February 27, 2018 5:33 PM
  • Also struggling with this issue. Shocking to see that MS has let a serious global issue like this go on for over a month without taking serious action. I'm guessing there must be vast numbers of corporate users affected. Talk about dropping the ball.
    • Edited by Rune Aamodt Friday, March 02, 2018 12:48 PM
    Friday, March 02, 2018 12:47 PM
  • This helped me:

    https://support.office.com/en-us/article/enable-users-to-sync-sharepoint-files-with-the-new-onedrive-sync-client-22e1f635-fb89-49e0-a176-edab26f69614#admincenter

    We moved from Groove.exe to new OneDrive.exe and it fixed the problem :)

    SHAREPOINT ONLINE FIX

    If you don't want to wait for your IT you can "FORCE" use of new client (from link above):

    This will need you to do:

    1) Stop syncing all sites from Sharepoint (in Groove):

    2) Delete/move Sharepoint folder on your HDD.

    3) Check if Groove (OneDrive for Buissnes) is not in startup list (prevent from starting)
    3.1 To be sure you can change 'groove.exe' filename to 'goove.exe.old' in Office directory.

    4) Download and run TeamSitePreview.reg from link above. Install new Onedrive from link if you are not using Windows 10.

    5) Restart OneDrive Client.

    6) Check if your OneDrive (blue) is connected to shrepoint user. If not "Add an account".

    

    6.1) Check Registry if fix is in place:

    [HKEY_CURRENT_USER\SOFTWARE\Microsoft\OneDrive] "TeamSiteSyncPreview"=dword:00000001

    6.2)  Restart Client if you did any change. 

    7) Go to Sharepoint Site (any) and click 'Sync". New Client should appear and start Sync Wizard :)

    8) Fallow instructions in Wizard. 

    9) Result:



    Monday, March 05, 2018 1:49 PM
  • Any update on this??? 

    Microsoft, you render your current sync client unusable for on-premise syncing. What do you do about that?! 

    Monday, March 05, 2018 3:18 PM
  • This does not work for on-premise syncing (what this thread is actually about!).
    Monday, March 05, 2018 3:21 PM
  • Thank you!! This Groove thing has been an utter mess, your solution is the first thing that's worked. I had 4 libraries synced via the old client, once I stopped 2 it went nuts trying to add the syncs back and I couldn't stop the last two. I just killed the process and deleted the whole lot.

    A frustrating, CPU consuming mess in comparison to Google Drive has been my experience so far. Let's hope this next version is better.

    Thanks for your detailed notes.

    Tuesday, March 06, 2018 1:55 AM
  • When I try that, I get 'Sorry we couldn't open the sync client. We couldn't process the URL. For help, please contact support.' That was on Windows 10 1709 and on Insider 1803 build 17101.

    I don't understand if there is something missing with step 6 above. If I try and add my on-premises Sharepoint it can't find it since it is looking for that at Microsoft or O365. That and in the system tray my OneDrive (personal) is white and not blue. My OneDrive for Business is blue. 

    If I try and install the OneDrive client from the link above, it says I have a newer version and to uninstall. I have 18.25.204.9. Uninstalled that, used the link from the article, it installs 17.5.107.8. Then not 5 minutes later it is back to 18.25.204.9. 

    I don't know if this only works with 17.5.107.8 but it doesn't work for me. 


    Wednesday, March 07, 2018 12:36 AM
  • Hi,

    I have OneDrive 18.025.0204.

    At step 6 I had both OneDrive Apps (white and blue) connected to both personal and SharePoint users (two different). Both user's folders were in sync with cloud (both working). See step 6 screen. 

    When accessing SharePoint sites, try using IE browser. 

    The result should look like:

    EDIT:

    Use this in IE: 

    odopen://sync?useremail=youruseremail@organization.com

    to check if OneDrive works.

    Wednesday, March 07, 2018 9:13 AM
  • Hi,

    I have OneDrive 18.025.0204.

    At step 6 I had both OneDrive Apps (white and blue) connected to both personal and SharePoint users (two different). Both user's folders were in sync with cloud (both working). See step 6 screen. 

    When accessing SharePoint sites, try using IE browser. 

    The result should look like:

    EDIT:

    Use this in IE: 

    odopen://sync?useremail=youruseremail@organization.com

    to check if OneDrive works.

    Thought I'd give it a try and see if it worked for our OnPremise installation too, but sadly no luck.

    Getting the error: Sorry, we couldn't open the sync Client. We couldn't prosess the URL.

    Basically the correct OneDrive is being started but it doesn't know what to do with the OnPremise links.

    So back on the waitinglist then ... could Microsoft please hurry up? Or at least react to our ticket? Or to this post? Anything?!


    Thursday, March 08, 2018 1:52 PM
  • Hi Andy,

    Pity it not worked for your installation.

    I don't know what can be the reason :(

    Maybe fallow the links in article, like "Transition from previous OneDrive for Business" on bottom of the page I linked. 

    Friday, March 09, 2018 8:10 PM
  • Following.  Same issue here.  It hogs so much CPU the fans have to start up and run at full blast literally 24 hours a day until I stop OneDrive manually.
    Sunday, March 11, 2018 5:14 PM
  • Just wanted to say that we are indeed STILL waiting for Microsoft to get back to us! It has been almost a month that we did last hear from them. To keep such a bug in there for this long without saying a word what's going on despite the fact you pay for them to look into it is just really lousy.
    Friday, March 23, 2018 7:07 AM
  • It looks like this issue should be fixed in Version 1803 (Build 9126.2098) per https://technet.microsoft.com/en-us/office/mt465751.aspx.  Currently this version appears to be available for the Monthly Channel (Targeted) and Semi-Annual Channel (Targeted).

    I do not have access to Version 1803 yet.

    OneDrive for Business: Non-security updates

    This channel release contains the following non-security updates:

    • Fix an issue where OneDrive for Business (Groove.exe) consumes one CPU core’s worth of CPU (for example, 25% on a 4 core CPU) in Task Manager for extended periods of time.

    Tuesday, March 27, 2018 2:14 PM
  • Glad to see this is finally getting fixed.

    It's not just high cpu usage that bothers me - it's the unnecessary wear on the hardware that I really don't like.

    Constant temperatures of about 170 fahrenheit on my laptop's cpu (normally around 110 when idle), and it chews through huge quantities of disk I/O: on my 23Mb One Drive folder it can get to almost 200GB of reads and around 5GB of writes on a day when I edited a single 4Kb text file  :-(

    I've resorted to a batch file that kills Groove.exe every 2 minutes or so to make sure things can run reasonably normally.
    Wednesday, March 28, 2018 8:13 AM
  • I had the same issue. The answer for me was to launch One Drive and enter my ID. Now everything is synced under One Drive and not One Drive for business. The transition was really smooth.

    "OneDrive for business (Groove.exe) has been taken over by the new sync client i.e. OneDrive.exe"

    https://answers.microsoft.com/en-us/msoffice/forum/msoffice_onedrivefb-mso_win10-mso_o365b/onedrive-for-business-grooveexe-error/9ac91320-4b8a-4b28-a481-9d4d9f449bbf

    And no more high CPU usage :)
    • Edited by Pattefolle Thursday, March 29, 2018 2:19 PM
    Thursday, March 29, 2018 2:16 PM
  • Just got 1803 on my Technet install of Office 2016. GROOVE.EXE is version 16.0.9126.2116. Opened a ~150k Excel file, edited it, saved it, watched the OneDrive for Business icon do the sync animation, stop, and then say everything is up to date. Saw the icon on the file I was working on go from a sync icon to a green check. 

    GROOVE.EXE is sitting at 0% CPU ~5 minutes later.

    Is it fixed? Is it really fixed? No April Fool's? 


    Monday, April 02, 2018 7:14 PM
  • The recent Office 365 Update 1803 (Build 9126.2116) of the monthly Update Channel seems to now finally have fixed this issue! So far I have not been able to reprodce the high CPU-Usage after installing this update.

    The only thing that bothers me is that we did not yet get any update on our support ticket from Microsoft. Probably will have to wait another two months on that... at least the problem Looks to be solved now!

    Tuesday, April 03, 2018 6:21 AM
  • That update indeed now finally fixed it for us! There is no more constant CPU usage on our clients after this update.

    Tuesday, April 03, 2018 6:23 AM
  • This update also finally fixed the issue for us here as well. No April fools!

    Tuesday, April 03, 2018 6:24 AM
  • I don't have the problem anymore with Office 365 Update 1802 (Build 9029.2253) monthly chanel (32-bits).

    Hopefully will be the same with 1803

    Edit April 6th 2018: it was better for 24h but failed again after... will check with 1803 as soon as it's deployed
    • Edited by suaz Friday, April 06, 2018 8:28 AM
    Thursday, April 05, 2018 1:51 PM
  • Hi, where is it mentionned Monthly Channel (targeted)? Since when i follow the link you posted it's only mentionned 3 channels starting from Monthly Channel.

    Not available yet through monthly channel though...

    Friday, April 06, 2018 7:49 AM