none
Option help.. turn off events for controls in Editor, Visual Studio 2013

    Question

  • OK.. not even sure how to ask this.. hopefully someone knows what I am talking about.

    When I'm in the code editor window.. VB.net, any form.. any control.. I start typing the control.. Textbox1, Listbox57, whatever.. autocomplete fills in the control name, except that when I upgraded to VS 2013, now the default isn't the control like; Textbox1, it's Textbox1_TextChanged, or Listbox57_WhateverEvent... instead of just the control.  Which is very frustrating.. why is/was this changed?  Autofill/autocomplete is useless now with this.

    How can I turn this functionality off?  I just want it to list the controls.. not the events available.. when I'm in the editor typing code.

    Please help!

    Thursday, May 19, 2016 4:16 PM

All replies

  • Hi ColtsFanMN,

    Which version of Visual Studio 2013 do you using? Please check whether you have installed the latest update for Visual Studio 2013. If not, please download and install it from below link.

    https://www.microsoft.com/en-sg/download/details.aspx?id=48129

    In my opinion, the control name and control event will be listed when I typing the first character as following screenshot shows. And the event should have been added into your code, otherwise, it won't shown in the intelligence list.

    Please check whether you set correct settings for VB Text Editor from Tools -> Options -> Text Editor as below image shows.

    If possible, please provide some screenshots to help us understanding your problem. Thanks.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.


    Saturday, May 21, 2016 5:02 AM
    Moderator
  • Thanks Weiwei .. I appreciate the response.

    In your first screenshot, it shows the event Click in the options, THAT is what I want to remove.

    This serves NO purpose for me, and in my code window, is the default entry (not Button1 as shown) so it removes any real purpose of the intelligence list, since I either have to click with my mouse or arrow up/down to the entry I want.

    I have and do keep my version updated, but the patch, in truth, has nothing to do with this issue, it appeared in VS2013, and I can't find the option that will turn it off.  I have my options set as you show above, and have unchecked them also, no change. 

    I just want the events, 'click' in this case, to not show in the intelligence list, as you call it.  Is this possible?  If not, I may roll back to a previous VS version.. this is costing me time, and is quite basically, a useless feature.

    Thanks again for your help.

    Monday, May 23, 2016 1:14 PM
  • Hi ColtsFanMN,

    The Click event in my first screenshot will be listed, because I have a click event for my button added in my code-behind. If I don't add click event for my button, it won't list in the intelligence window. Please see below screenshot, if I don't add click event for my button, it will not list in intelligence window.

    So it is listed in intelligence list or not, which is based on the event added into code-behind or not. And I don't find such settings about filter the control event in intelligence list. It should be default design for Visual Studio. If any idea for this design, I suggest you submit your ideas to Visual Studio User Voice.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, May 24, 2016 1:55 AM
    Moderator