locked
Your licence is for an older version of xamarin.ios RRS feed

  • Question

  • User9850 posted

    Hello,

    the company I am working for is considering using xamarin for app development. I am in charge to test it for functionality before we purchase xamarin.

    We want to use the xamarin plugin for visual studio. I installed xamarin studio and everything that belongs to it. I created a new account and got the free trial. I was able to build the android version of the tasky example with visual studio and deploy it to an android device.

    Now I tried to do the same for the ios version and deploy it to an Iphone.

    The problem is, when I open the taskytouch / taskios solution, I am prompted to purchase a licence. "Your licence is for an older version of xamarin.ios You must renew your licence to continue using xamarin.iOS Unknown Edition"

    Shouldn't I be able to open/build the iOS version too with my trial? The trial definitely didn't expire, and my xamarin version is a fresh installation, so my xamarin.iOS version is not too old, I double-checked that.

    I tried to uninstall and delete all xamarin-related stuff and re-install it. Same error.

    We would really like to try xamarin a little before paying 1k for it. I assume the mistake I describe is a bug, and I hope someone can help me to fix it.

    I will try another machine in the meantime ...

    Thank you very much for your assistance.

    Regards, Seb

    Friday, April 26, 2013 4:13 AM

All replies

  • User9608 posted

    Getting the same error as Sebastian, haven't started a trial yet and the option to start a trial doesn't appear for me when loading an iOS project, I only get the "Purchase a license" option and it's telling me my license is for an older version of Xamarin.iOS.

    Guy

    Monday, April 29, 2013 3:40 AM
  • User9850 posted

    try installing this one http://download.xamarin.com/MonoTouchforVisualStudio/Windows/mtvs-1.1.200.0.msi got the link from the email support and it worked for me... good luck

    Monday, April 29, 2013 3:42 AM
  • User9608 posted

    I ran MonoTouchActivation on the mac as suggested by John (http://forums.xamarin.com/discussion/3449/cant-create-project-via-visual-studio-2012#latest) and that did the trick.

    Thanks!

    Monday, April 29, 2013 4:07 AM