none
Unable to view reports in Visual Studio Report Viewer - Security issue? RRS feed

  • Question

  • Hi

    I've been developing a web app with Visual Studio 2010 and SQL 2008 Express for a while on windows server 2003. The app is now ready to go live so we purchased a new web server (win server 2008) and SQL 2008 R2 Standard to host it. I transferred the database and app to the new server and began configuring the report server on the new machine. After a bit of messing about and pretty much trying to mirror the settings from the previous report server, everything seemed to be configured correctly - reports / datasources are deployed and I can view reports via the report manager over the network. I changed the report server url for my report viewers in the visual studio project but when I attempt to access any page containing a report (in debug), the page just times out. The annoying thing is that I don't even receive an error message, the page will stay as 'waiting for page...' for as long as you care to wait. I also tried typing the report server url into IE and browsing to the report - although I was able to access the folders and see the reports, as soon as I opened one, I got exactly the same problem. I then tried deploying the app to the server to see if it behaved any differently whilst deployed. The result was slighly different this time and although it mostly just timed out I once saw the following error...

    Report Viewer Configuration Error
    The Report Viewer Web Control HTTP Handler has not been registered in the application's web.config file. Add <add verb="*" path="Reserved.ReportViewerWebControl.axd" type = "Microsoft.Reporting.WebForms.HttpHandler, Microsoft.ReportViewer.WebForms, Version=10.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" /> to the system.web/httpHandlers section of the web.config file, or add <add name="ReportViewerWebControlHandler" preCondition="integratedMode" verb="*" path="Reserved.ReportViewerWebControl.axd" type="Microsoft.Reporting.WebForms.HttpHandler, Microsoft.ReportViewer.WebForms, Version=10.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" /> to the system.webServer/handlers section for Internet Information Services 7 or later."The permissions granted to user 'IIS APPPOOL\DefaultAppPool' are insufficient for performing this operation. (rsAccessDenied)"
     
    I also managed to get the error below by running the browser as administrator...

    The permissions granted to user 'ARMSTRONG\ARMWEBSVR$' are insufficient for performing this operation. (rsAccessDenied) 

    I've spent the best part of a day playing around with this and still haven't got anywhere, if anyone could offer any advice, I would be very grateful.

    Regards

    Steve

    Monday, December 20, 2010 8:49 AM

Answers