locked
Adding userendpoint to Application endpoint's Default routing UCMA 3.0 RRS feed

  • Question

  • Hallo,

    I have established an Application endpoint with the following properties

                   settings.IsDefaultRoutingEndpoint = true;
                    settings.AutomaticPresencePublicationEnabled = true;
                    settings.Presence.PresentityType = "automaton";
                    settings.Presence.Description = "AlwaysOnlineBot";

    then established an userendpoint with userendpointsetting having the following properties

       userEndpointSettings.AutomaticPresencePublicationEnabled = true;
        userEndpointSettings.Presence.PreferredServiceCapabilities.AudioSupport = CapabilitySupport.UnSupported;

    If i start the application for the first  time and a call arrives for established user endpoint it is not received by the application endpoint. Starting the app for the second time the application endpoint receives the calls for the user endpoint.

    So the default routing works for the user endpoint that were established  at the time of establishment of the Application endpoint. It doesn't work for user endpoints that were established after  Establishing Application endpoint.

    Is there a way of adding newly established user endpoints to application endpoint's Default Routing?

    Thanks in advance

    cheers

    joseph

                       




    Monday, July 22, 2013 2:29 PM

Answers

  • Try enabling audio support for the endpoint as a first step. There may be other issues that are contributing to the problem though.

    Michael Greenlee | linkedin: http://www.linkedin.com/in/michaelgreenlee | blog: http://blog.greenl.ee

    Thursday, August 8, 2013 9:25 PM

All replies

  • I'm not sure you'll be able to get this working consistently. But one thing I notice is that you are disabling audio support for the user endpoint, so audio calls for that user are not going to be routed to your application by Lync Server. That may be contributing to the problem.

    Michael Greenlee | linkedin: http://www.linkedin.com/in/michaelgreenlee | blog: http://blog.greenl.ee

    Tuesday, July 30, 2013 2:55 PM
  • Hallo,

    Thanks for your reply.

    From your blogs i understood that, this is the setting to receive the calls at default routing (application endpoint). I have registered for incoming calls at the application endpoint.

    If i enable the audio support for user endpoint, will i be able to receive the call through the default routing (application endpoint)?.

    My goal is to receive all calls through default routing , in my use case i establish user endpoints after establishing application endpoint. How to do this?

    Thanking you.

    cheers

    joseph

    Wednesday, July 31, 2013 12:05 PM
  • Try enabling audio support for the endpoint as a first step. There may be other issues that are contributing to the problem though.

    Michael Greenlee | linkedin: http://www.linkedin.com/in/michaelgreenlee | blog: http://blog.greenl.ee

    Thursday, August 8, 2013 9:25 PM