locked
Cannot Update 'companyName' attribute RRS feed

  • Question

  • Good Afternoon All,

    Just wondering if there is a way to populate the Azure AD Attribute 'companyName' for Azure AD users in the directory.  When attempting to update this via the Graph API it shows as a read-only property.  I've checked in both my development and production tenants and its not populated.  For synchronised users the attribute appears to be written.  For directories without AD sync the property is still read-only.

    Is this value set globally somewhere within the tenant or API?

    

    Tuesday, November 28, 2017 1:53 AM

Answers

  • Never Mind - this attribute is inherited from the Display name property of the organisation but is not visible in the Graph API directly.
    Tuesday, November 28, 2017 4:56 AM

All replies

  • Never Mind - this attribute is inherited from the Display name property of the organisation but is not visible in the Graph API directly.
    Tuesday, November 28, 2017 4:56 AM
  • Thanks for sharing this information on the forum.

    Have a good one!

    Tuesday, November 28, 2017 5:41 AM
  • I have this attributes sync'd from an OnPrem AD and for the users that are sync'd the value is being set from the Company attribute in my AD.

    I have not found any way of setting this attribute for a "cloud" user though.

    I have some signature software that reads this property and all my cloud users just have a blank.  I'm scouring the web at the moment trying to work out where to set it.


    Richard H

    Thursday, January 25, 2018 7:08 AM
  • Trying to accomplish the same thing, setting companyName for Azure AD-users.

    Unfortunately, it seems this property is still off-limits, with no indication of when it will change:

    https://stackoverflow.com/questions/46725871/microsoft-graph-user-companyname-not-writable?rq=1

    Monday, February 12, 2018 10:10 AM
  • Came to the same conclusion through a different route and wound up here as the last hope. Note that the doc referred to in the cited post _has_ been updated to say that it is read-only. For those of us with an on prem directory that syncs over ADConnect it does appear to be mapped to the on prem "company" attribute in user entries. Hard to fathom why this can't be made writable from the cloud side. Another mystery of life, I guess.
    Tuesday, March 13, 2018 1:00 AM