locked
Publish ASP.NEt web page with IIS 5.1 RRS feed

  • Question

  • User-773320996 posted

    Hi, I am trying to publish my first web page by IIS 5.1.  I could do that if the default is xxxx.htm, but not if it is xxxx.aspx.  I would like to know how to publish my ASP.NET website on the internet using IIS.

    How I did with .htm webpage:

    *  IIS 5.1 is in Windows XP Pro.  I upgraded from Windows XP home.

    *  I downloaded .NET 2.0 framework.  I did not do anything with this. 

    *  I created the Web page by Visual Web Developer Express Edition.

    *  My local folder is C:\Inetpub\wwwroot\testASP\Default.htm

    *  My IIS path is http://(computername)/testASP/

    I can see this on the internet.  In the "textASP" file, I have several .aspx files.  Thoese run ok with the local host.  But this one does not work:

    http://(computername)/testASP/Default.aspx

     

     

    Wednesday, February 14, 2007 2:04 PM

All replies

  • User-823196590 posted
    Can you please be more detailed about what "does not work" means?  Is there an error message?
    Wednesday, February 14, 2007 2:31 PM
  • User-773320996 posted
    >Can you please be more detailed about what "does not work" means?  Is there an error message?
     
    The page just says, "The page cannot be found".  Again, the path was:
     
     
    It looks like any .htm file can be posted on the internet, but .aspx files can not be posted on the internet... I am wondering if I need any special set up for IIS, ASP.NET, .NET or else?
     
    I created "testAsp" folder.  This folder now contains Default.htm, Default.aspx, and other several folders.  When I open Default.aspx within Web Developer 2005 Express Edition, it works.  The fils is a ASP.NET file containing form.  The page takes the input of the user's name, and then displays it as a label. 
     
    Wednesday, February 14, 2007 4:44 PM
  • User-823196590 posted

    A 404 error?  Are you running URLScan? 

    You can access http://mycomputername/testasp/default.htm over the internet?

    Wednesday, February 14, 2007 4:54 PM
  • User-686003401 posted

    Hi,

    I have the same problem.

    it works with http://localhost/Testing/Default.aspx

     but my IIS behind a router, I installed no-ip and port forwarding port 80.

    http://dns.com/Testing/Default.aspx

    but it still does not work. Can anyone help?
     

    Thursday, March 15, 2007 1:31 PM
  • User-823196590 posted
    Is your ISP blocking port 80?  Most of them do.  Try a different port.
    Thursday, March 15, 2007 2:46 PM
  • User1356161706 posted

    In XP SP2 the firewall is also blocking port 80.  Have a look at the following article:

    http://www.windowsecurity.com/articles/Customizing-Windows-Firewall.html

    Hope this helps.

     

    Thursday, March 15, 2007 3:39 PM
  • User-686003401 posted

    Thanks for your replied. I tried port 81. is still the same... :(

     http:/localhost:81/AJAX/Default.aspx     //works

    http://mydnsname.com:81/AJAX/Default.aspx    //not working

    Thursday, March 15, 2007 7:44 PM
  • User-823196590 posted

    Did you reconfigure your router correctly?

    What happens if you ping mydnsname.com?  Does it give the right IP?

    Friday, March 16, 2007 8:49 AM
  • User-686003401 posted
    will try later.. thanks anyway!
    Friday, March 16, 2007 8:53 AM
  • User-686003401 posted
    I tried, it give the correct IP address..It still does not work, why?
    Sunday, March 18, 2007 9:29 AM
  • User-823196590 posted
    What happens exactly?
    Tuesday, March 20, 2007 8:46 AM
  • User-686003401 posted

    I changed back to the original port 80.

    http://localhost/AJAX/Default.aspx //work

    http://mydnsname/AJAX/Default.aspx

    //not working, and displayed Object Not Found The requested URL '/AJAX/Default.aspx' was not found on the RomPager server. Return to last page

    Tuesday, March 20, 2007 8:43 PM
  • User-823196590 posted
    I didn't see a clear response from you regarding Windows Firewall - are you running that?  Are you sure your router is configured correctly?  If it works from http://localhost/ then IIS is working correctly and this appears to be a networking issue. What's RomPager?
    Wednesday, March 21, 2007 8:08 AM
  • User-686003401 posted

    Hi,

    I'm not sure what's RomPager server.

    But when try to access http://mydns/AJAX/Default.aspx   it displayed this error message.

    Object Not Found

    The requested URL '/AJAX/Default.aspx' was not found on the RomPager server.

    Return to last page

     

    Wednesday, March 21, 2007 9:09 AM
  • User-823196590 posted
    Apparently then something is blocking IIS and the request is never reaching IIS.
    Wednesday, March 21, 2007 10:04 AM
  • User-823196590 posted
    Apparently RomPager is an embedded web server on a network device, perhaps your router?  A simple Google search found that info.  It looks like you do not have your router configured properly.  Please consult your router's documentation on how to configure port forwarding for web traffic and perhaps to disable remote administration.
    Wednesday, March 21, 2007 10:07 AM