locked
Weird drawing artefacts and strange button behaviour (Pauluss86) - 1/12/2008 1:04 PM PST RRS feed

  • Question

  • By: Pauluss86


    Howdy!
    
    I've been fiddling around with Expression Blend 2 September Preview for some 
    time now and it's great, however there are 2 issues which have been bugging 
    me.
    I've created a button with a custom template and certain animations when 
    events are triggered, e.g. MouseEnter, MouseDown, etc.
    Now the first problem I have is that MouseDown is _only_ triggered when I 
    right-click the button. Left-clicking has no effect whatsoever. I've tried 
    changing the MouseDown event to a MouseLeftButtonDown, but to no avail (even 
    then right-clicking still works though).
    The second problem is purely visual and only happens when a button animation 
    is played after the application window has been resized. Strange lines appear 
    around the button almost as if the backbuffer hasn't been properly cleared. 
    Minimizing and and then restoring the application makes the lines disappear 
    but they reappear if an animation is triggered again. By the way, these lines 
    also occasionally appear in Expression Blend itself. It's kinda hard to 
    explain how it looks, so here's a link that shows what I mean: 
    [url]http://img168.imageshack.us/img168/3151/weirdlinestd4.png[/url]
    
    Any suggestions on how to solve these problems will be much appreciated!
    Friday, February 22, 2008 4:07 PM

All replies

  • Pauluss86


    Okay, second problem is solved now! It had to do with me setting custom 
    settings in ATI's Catalyst Control Center; which makes games look nicer but 
    isn't really compatible with nor necessary for Blend :P First problem still 
    persists though..
    Saturday, February 23, 2008 12:43 AM
  • Pauluss86


    'Solved' the first problem also.. 
    If I use the PreviewMouseDown event the button is successfully pressed if I 
    left-click on it. However this seems a bit strange to me, why does 
    left-clicking fire the PreviewMouseDown event but not an ordinary MouseDown 
    event? It just feels wrong.. the 'solution' is more like a workaround imho. 
    Did anyone else notice this behaviour? I run Blend December preview now by 
    the way (Vista Ultimate 64bit).
    
    This thread is becoming a boring monologue, but hopefully someone might find 
    this useful information :)
    Saturday, February 23, 2008 12:44 AM
  • Unni Ravindranathan (MS)


    Thanks for sharing your solutions! :)
    
    -Unni
    
    "Pauluss86" <Pauluss86@discussions.microsoft.com> wrote in message 
    news:57546214-16BA-46CB-9767-1F16C5247930@microsoft.com...
    > 'Solved' the first problem also..
    > If I use the PreviewMouseDown event the button is successfully pressed if 
    > I
    > left-click on it. However this seems a bit strange to me, why does
    > left-clicking fire the PreviewMouseDown event but not an ordinary 
    > MouseDown
    > event? It just feels wrong.. the 'solution' is more like a workaround 
    > imho.
    > Did anyone else notice this behaviour? I run Blend December preview now by
    > the way (Vista Ultimate 64bit).
    >
    > This thread is becoming a boring monologue, but hopefully someone might 
    > find
    > this useful information :) 
    
    Saturday, February 23, 2008 12:44 AM