locked
Unable to Build Applications | The package repository is corrupted

    Question

  • Ever since I updated Visual Studio 2012 Express, I am unable to build any solutions whether they be just freshly created or previous solutions. I always get the error; "DEP0600 : The following unexpected error occurred during deployment:
    The package repository is corrupted. (Exception from HRESULT: 0x80073CFE)". I have Windows 8 Pro (x64) if that helps. Any help would be appreciated.
    Sunday, April 21, 2013 5:07 PM

Answers

  • I ended having to do a System Refresh from the PC Settings->General->Refresh your PC w/o affecting your files. It works now. I am able to compile my solution and run the Windows Store app. Now I have to reinstall all of my apps! Not happy about that. After the refresh, first thing I installed was VS 2012 w/ Update 2. After that, I loaded my solution and compiled and ran. It worked. The refresh makes a list of all of the apps you had installed and saves it as a html doc to your desktop. So dumb. Hope this helps you.

    - David

    • Marked as answer by Song Tian Tuesday, May 7, 2013 7:04 AM
    Wednesday, April 24, 2013 10:05 PM

All replies

  • Hi Changer098,

    Could you share your project? And I will try to reproduce on my side.


    Roy
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Tuesday, April 23, 2013 5:22 AM
  • I get this same error using a new project for Windows Store. I don't get it. Using VS 2012 Pro. 11.0.50727.1 RTMREL
    Tuesday, April 23, 2013 6:46 PM
  • That's just it. Even if I start out with a new project (Say the Grid App Template or something), I will get this error when trying to build the solution. I've tried reinstalling multiple times to no success.
    Tuesday, April 23, 2013 10:52 PM
  • I ended having to do a System Refresh from the PC Settings->General->Refresh your PC w/o affecting your files. It works now. I am able to compile my solution and run the Windows Store app. Now I have to reinstall all of my apps! Not happy about that. After the refresh, first thing I installed was VS 2012 w/ Update 2. After that, I loaded my solution and compiled and ran. It worked. The refresh makes a list of all of the apps you had installed and saves it as a html doc to your desktop. So dumb. Hope this helps you.

    - David

    • Marked as answer by Song Tian Tuesday, May 7, 2013 7:04 AM
    Wednesday, April 24, 2013 10:05 PM