none
How to Increase the size of Attachment file in Infopath forms

    Question

  • I am using infopath forms for Project proposal ...In that form i need to attach document more than 6 MB . Its throwing error

    Is there n ways to add file

    Thanks in Advance 


    • Edited by Mike Walsh FIN Wednesday, June 24, 2009 9:47 AM waiting for reply removed. Don't push us
    Wednesday, June 24, 2009 9:40 AM

Answers

All replies

  • Hi,

    The fix lies in either the machine.config file or the web.config file of the MOSS server.  You'll need to increase the 'maxRequestLength' value in order to upload larger files.  Ex:

    <httpRuntime maxRequestLength="8192" />

    Verify below link for more idea.

    http://www.k2underground.com/blogs/fromthebench/archive/2008/03/10/infopath-file-attachment-size-limit.aspx




    Anuma Chinthapalli / http://www.GGKTech.com
    Wednesday, June 24, 2009 10:43 AM
  • I was facing similar issue while trying to attach the files to Infopath form. I wanted to allow user to upload upto 50 MB. I did following to resolve this issue:

    • Go to Central Administration site of SharePoint server, select respective Web Application then open Web Application general settings
    • Set Maximum Upload Size   to 50MB
    • Go back to Central Admin & open configure info-path form services under info-path form services
    • Set Form Session State --> Maximum size of form session state value to 51200  KB( the default is 4096KB). 
    • Done

    It should be working !!!!!!!!!

     


    Monday, May 24, 2010 5:38 AM
  • Mohd, those 2 settings arne't specifically for InfoPath file attachments.  The first one affects the max file upload size for the entire Web Application.  You wouldn't change this setting just for InfoPath files, and I think 50MB is the default anyway.  The other one is sessio nstate, which is not related to file attachments, but rather how much it will cache in the session state.  I would consider a 50MB session state to be much too high.
    SharePoint Architect || Microsoft MVP || My Blog
    Monday, May 24, 2010 6:04 AM
  • My experience has been that Attachment size is directly related to the form session state parameter in InfoPath Configuration.  I don't like the implications of this: if you raise it--it raises for everyone--which means the machine is allocating a lot more space per user that could be used elsewhere.
    Thursday, June 24, 2010 12:55 PM
  • Clayton,

    The settings advised by Mohd, will it resolve the problem ?  Or do you have any resolution to this  ?

    Wednesday, July 07, 2010 5:18 AM
  • hey guys,
    i've tried some of these approaches, such as:
    - Configure InfoPath Forms Services
    - Web Application General Setting
    - maxRequestLength in SharePoint Web.Config

    However, when creating a new InfoPath Form in SharePoint Web Browser,
    when i even Attach a File that is about 3.5MB, the Browser just seems to hang up.
    I just want users to Upload around 5MB File to InfoPath without any issues.
    Does anywhere out there have the same problem as me?
    Can anyone help me out?

    Tuesday, August 03, 2010 6:45 AM
  • It could also be the problem of network bandwidth between the machine from where you are trying to upload file and the server, Check the network bandwidth with the network team
    Thursday, February 23, 2012 6:36 PM