locked
XCode 6.1 iOS Simulator WebView Issue displaying PDF, DOCX, ... RRS feed

  • Question

  • User61409 posted

    I updated my XCode from 6.0.1 (iOS Simulators 8.0) to XCode 6.1 (Simulators 8.1) yesterday and noticed that the WebView isn't displaying the PDFs, DOCXs and TIFs (so far these are all that I've tried). Rolling back to XCode 6.0.1 the same code works fine. Please note that I am using Xamarin Forms (latest stable Xamarin) and haven't upgraded to Yosemite yet. Few questions: 1. Is this an expected behavior with XCode 6.1 (Simulators 8.1)? 2. Do I need to do something (config, etc) to get this working on XCode 6.1? 3. Lastly, are we good to go (Xamarin development wise) running under Yosemite?

    Thanks for the help in advance.

    Thursday, October 23, 2014 1:44 PM

All replies

  • User14 posted

    Hey @Carlo, I have not see this issue with the simulator - do devices running 8.1 work fine?

    Regarding Yosemite, there has been a known issue with people being unable to 'pair' from Visual Studio to their Mac Build Host once upgrading it to Yosemite... the fix is imminent but that is the main issue I've heard of about the upgrade. I myself have not upgraded yet so I can't offer any first-hand experience.

    Thursday, October 23, 2014 5:32 PM
  • User61409 posted

    Hi @CraigDunn?, I haven't tried it yet on actual 8.1 devices yet. Thanks!

    Thursday, October 23, 2014 5:37 PM
  • User61409 posted

    @CraigDunn, is this something that somebody can re-test at Xamarin? Thanks again!

    Friday, October 24, 2014 3:33 PM
  • User61409 posted

    @CraigDunn?, Running on Xamarin.iOS 8.4.0.16 this is working fine now with XCode 6.1. I didn't test it when I got the 8.4.0.15 so I am not sure when exactly it got fixed. Didn't see anything on the release notes that looks related to this. Anyways, it works now. Thanks again!

    Monday, November 3, 2014 8:40 PM