locked
Mirroring not functioning RRS feed

  • Question

  • Hello,

    I am trying to set up database mirroring on 2 instances of SQL Server 2005 Evaluation version on the same Win XP machine.

    The problem that I am having is everytime I try to configure mirroring between the two instances I provide the server address in the following syntax

    TCP://[Machine name]:[port number]

    SQL server gives me an error to provide a Fully Qualified Domain Name and does not enable mirroring. The port numbers that I am using are 5022 and 5023 for the instance sharing the mirror and the instance hosting the mirror respectively. but I dont know why this is not working.

    Any suggestions would be appreciated. I am not using a witness server.

    BR

    Aashan
    • Changed type aashan Monday, December 28, 2009 1:35 PM
    Thursday, December 17, 2009 11:48 PM

All replies

  • What SP level are you using with SQL SERVER 2005.?
    Check that from select serverproperty('productlevel')
    or
    select @@version


    Normally RTM version of SQL server 2005 has mirroring disabled by default .. To enable database mirroring for evaluation purposes, use trace flag 1400 during startup and restart SQL server.
    If you are using RTM version then do this ,

  • Goto RUN –> Type sqlservermanager.msc
  • Right click on SQL Server(instancename) service and click on properties
  • Click on Advanced tab
  • In the startup parameters enter this ;-T1400 and click on OK
  • Restart SQLservices and then try configuring db mirroring
  • Or

  • Update SQL Server to latest service pack
  • IF THIS IS NOT THE CASE , please post the complete error message.


    Thanks, Leks
Friday, December 18, 2009 2:39 AM
Answerer
  • When SQL Server 2005 was first released for general availability, database mirroring was available only for evaluation purposes and had to be enabled via trace flag 1400. With SQL Server 2005 SP1, database mirroring became completely supported as a general feature, with no restrictions.

    SQL server gives me an error to provide a Fully Qualified Domain Name and does not enable mirroring


    System Address : 

    "For the system name of a server instance in a database mirroring configuration, you can use any name that unambiguously identifies the system. The server address can be a system name (if the systems are in the same domain), a fully qualified domain name, or an IP address (preferably, a static IP address). Using the fully qualified domain name is guaranteed to work. 

    Please refer the following MSDN link :
    http://msdn.microsoft.com/en-us/library/ms189127.aspx :"Troubleshooting Database Mirroring Deployment"

    ------------
    Thanks,Suhas V
    Friday, December 18, 2009 4:39 AM
  • hi, please refer to this link i have tried to explain step by step of creating database mirroring. please refer to my blog http://www.my-sql-share.blogspot.com

    -Vijay PMP, MCTS http://www.my-sql-share.blogspot.com Please click Mark as Answer if this had solved your issue
    Sunday, December 20, 2009 3:46 PM
  • Dear Lekss,

    yes I am running an evaluation version and I upgraded to service pack 3. I also added the startup parameters as you suggested just in case but still it is not working.

    The server network addresses are

    Principal:    TCP://winxp-001:5022
    Mirror:       TCP://winxp-001:5023

    The exact error that I get is


    "one or more server network addresses lacks a FQDN.. Specify FQDN for each server, and click start mirroring again.

    The syntax for a FQDN TCP address is:
    TCP://<computer|_name>.<domain_segment>[.domain_segment>]:<port>"

    But still no luck

    Aashan


    Monday, December 28, 2009 1:58 PM
  • HI,

    Are you trying to mirror two instance in same Machine?, If so Check they are having different port Number or even craeting alias for named instance will be usefull.


    Regards, Sudhagar.G
    Wednesday, December 1, 2010 5:41 AM