locked
Analyze in Excel without any Tabular data - SSAS 2012 Tabular RRS feed

  • Question

  • Hi,

    I've implemented and processed a tabular model. I can browse the cube and see the related data inside Management Studio. Inside SSDT, when I run the Analyze in Excel I cannot see any data for the pivot table.

    The server hosts Excel 2013 and SQL Server 2012 with SP1 that I haven't installed. For the engine instance I've noticed the version 11.0.3128 and for tabular instance I've seen the version 11.0.3000. Moreover, for SSDT I can read Microsoft Visual Studio 2010 - Version 10.0.40219.1 SP1Rel.

    Also when I open a new Excel 2013 file and add a SSAS connection that points to the tabular model I cannot see any data.

    Any ideas to solve this issue, please? Many thanks


    • Edited by pscorca Wednesday, July 3, 2013 2:49 PM
    Wednesday, July 3, 2013 2:47 PM

Answers

  • Hi,

    I've implemented and processed a tabular model. I can browse the cube and see the related data inside Management Studio. Inside SSDT, when I run the Analyze in Excel I cannot see any data for the pivot table.

    The server hosts Excel 2013 and SQL Server 2012 with SP1 that I haven't installed. For the engine instance I've noticed the version 11.0.3128 and for tabular instance I've seen the version 11.0.3000. Moreover, for SSDT I can read Microsoft Visual Studio 2010 - Version 10.0.40219.1 SP1Rel.

    Also when I open a new Excel 2013 file and add a SSAS connection that points to the tabular model I cannot see any data.

    Any ideas to solve this issue, please? Many thanks


    Hi pscorca,

    This issue occurs because the SQL Server 2012 components reference mismatched assemblies. Have you install Cumulative Update 1 for SQL Server 2012 SP1? If so, please try to install Cumulative Update 2 for SQL Server 2012 SP1.

    If not, we recommend that you install the Non Security Update for SQL Server 2012 SP1. For detail information, please see: http://support.microsoft.com/kb/2793634

    In addition, when creating a new Tabular model project in SQL Server Data Tools (SSDT) with SQL Server 2012 SP1 installed, on the New Tabular project options dialog, you can specify the compatibility level. You can choose between creating a new project to be deployed to an SQL Server 2012 SP1 Analysis Services instance or to an SQL Server 2012 Analysis Services instance (without Service Pack 1).

    For more informatuion, please see: http://technet.microsoft.com/en-us/library/jj674204.aspx

    At last, please open your SSMS and right-click on your Tabular database -> Select "Broswe..." option. Please drag the dimension and measure to see if will return Tabualr data or not. If not, please process your Tabular model.

    Best Regards,


    Elvis Long
    TechNet Community Support

    • Marked as answer by Elvis Long Friday, July 12, 2013 3:20 AM
    Thursday, July 4, 2013 9:31 AM

All replies

  • The model was to Compatibility Level 1100 and I've changed it to 1103. I've deleted the tabular db and redeployed the project, but any results.

    Also if I launch the Analyze in Excel from Management Studio I cannot see any tabular data.

    In the event viewer I cannot see any useful error messages.

    Any helps to me, please?

    Wednesday, July 3, 2013 3:52 PM
  • Any replies? Is there an Excel 2013 bug?

    Thanks

    Thursday, July 4, 2013 8:16 AM
  • Hi,

    I've implemented and processed a tabular model. I can browse the cube and see the related data inside Management Studio. Inside SSDT, when I run the Analyze in Excel I cannot see any data for the pivot table.

    The server hosts Excel 2013 and SQL Server 2012 with SP1 that I haven't installed. For the engine instance I've noticed the version 11.0.3128 and for tabular instance I've seen the version 11.0.3000. Moreover, for SSDT I can read Microsoft Visual Studio 2010 - Version 10.0.40219.1 SP1Rel.

    Also when I open a new Excel 2013 file and add a SSAS connection that points to the tabular model I cannot see any data.

    Any ideas to solve this issue, please? Many thanks


    Hi pscorca,

    This issue occurs because the SQL Server 2012 components reference mismatched assemblies. Have you install Cumulative Update 1 for SQL Server 2012 SP1? If so, please try to install Cumulative Update 2 for SQL Server 2012 SP1.

    If not, we recommend that you install the Non Security Update for SQL Server 2012 SP1. For detail information, please see: http://support.microsoft.com/kb/2793634

    In addition, when creating a new Tabular model project in SQL Server Data Tools (SSDT) with SQL Server 2012 SP1 installed, on the New Tabular project options dialog, you can specify the compatibility level. You can choose between creating a new project to be deployed to an SQL Server 2012 SP1 Analysis Services instance or to an SQL Server 2012 Analysis Services instance (without Service Pack 1).

    For more informatuion, please see: http://technet.microsoft.com/en-us/library/jj674204.aspx

    At last, please open your SSMS and right-click on your Tabular database -> Select "Broswe..." option. Please drag the dimension and measure to see if will return Tabualr data or not. If not, please process your Tabular model.

    Best Regards,


    Elvis Long
    TechNet Community Support

    • Marked as answer by Elvis Long Friday, July 12, 2013 3:20 AM
    Thursday, July 4, 2013 9:31 AM