none
[Windows 7 RC x86] Screen goes black. RRS feed

  • Question

  • Hi Everyone,

    I've tried the first Windows 7 beta on my laptop. (Dell Latitude D820 - Nvidia Quadro NVS 110M)
    It worked great and found no real big issues so I installed the new RC version. I formatted my disk so I was certain that it was a nice, clean install.
    (besides the WindowsXP installation that I use at work)

    After the install and first reboot I could use my native screen resolution of 1680x1050, but the screen keeps turning black. Sometimes the logon screen is visible, but on other occasions it's black too. When logged on, the active application-windows are visible if you look really closely, but it's so dark that nothing can be done. (I can't even find my mouse-cursor)
    At first it looked like a hardware problem, but since the problem doesn't occur on the WindowsXP installation (and the previous Windows 7 beta for that matter) it seems something goes wrong with the graphics driver of some sort. The Windows Event Log doesn't mention any problems.

    When I place my latop in a docking station/port replicator with an external screen attached there are no problems at all. I can use both screens with no problems whatsoever. I've searched through the NVidia forum's but found nothing useful. On other fora I found some work-arounds but nothing helped in this case. Since NVidia Drivers for Windows 7 aren't downloadable from nvidia.com but are only available through Windows Update I can't try any other driver. Most common NVidia Drivers are for GeForce cards and since I'm using a Quadro that won't help either.

    Is there a way to easily solve this? And do more people have these problems?

    If anyone needs more info, please ask.
    • Edited by Bart_Man Friday, May 15, 2009 8:34 AM forgot something.
    • Moved by ashawani_dubeyModerator Wednesday, June 10, 2009 8:23 AM not related (From:Social Bookmarks Discussion Forum)
    Friday, May 15, 2009 8:34 AM

Answers