none
EDI Validations missing in EDI Disassembler RRS feed

  • Question

  • Whenever a EDI interchange is received using EDIReceive pipeline the following validations are missing:

    1.    In Functional Group Trailer (UNE or GE), the total number of transactions in the group is not validated, i.e. it can contain any number.
    2.    In Functional Group Trailer (UNE or GE), Group control number matching the control number in the group header is not validated, i.e. it can contain any number.
    3.    In Interchange Control Trailer (UNZ or IEA), the count of the number of transactions is not validated, i.e. it can contain any number.
    4.    In Interchange Control Trailer (UNZ or IEA), the interchange control number is not validated, i.e. it can contain any number.

    A example of file which successfully processes inside Biztalk even though it is having the problems mentioned above is given below:

    UNA:+.? '
    UNB+UNOC:3+Sender:ZZ+Receiver:ZZ+081218:1003+109'
    UNG+IFTSTA+Receiver:ZZ+CARGOSMART:01+070601:1457+9+UN+D:96A'
    UNH+111+IFTSTA:D:96A:UN'
    BGM+350+0561438952+9'
    DTM+137:20081108110000:204'
    CNI+1+0560054943'
    STS+1+21'
    DTM+35:20081114100000:204'
    GID+10+5:EA+2:EA'
    GID+90001+5:EA+1:EA'
    PCI+10+1000004BATCH_001'
    GIN+PN+000000000550000252'
    GIN+PN+000000000550000252+Z008'
    UNT+12+111'
    UNE+12+123'
    UNZ+12+1099'

    It is applicable for both X12 and Edifact.

    Am I missing some configuration to enable these validation?
    • Moved by Ben Cline1Moderator Wednesday, February 3, 2010 6:00 AM Related to EDI (From:BizTalk Server General)
    Tuesday, February 2, 2010 4:11 AM

All replies

  • Hi,
        There are two modes in which Edi disassembler processes the message.

    1- Split Interchange
    2- Preserve Interchange.

    In the Split Interchange Edi disassembler split the document into ST-SE for X12 and UNH-UNT for EDIFACT. So in this mode we do not have information for UNZ,UNE,SE,GE. So it won't vaidate in this mode.

    In the Preserve Interchange mode Edi disassembler preserves interchange and keep ISA,GS,GE,IEA  UNB,UNG,UNE,UNZ. So in this mode we validate number of groups and control numbers.

    You can change the mode going to following settings:
    Party Edi Properties -> Party as Interchange sender(X12/EDIFACT) -> Validation and Ack Generation -> Inbound Batch Processing Option.

    Choose Preserve Interchange Suspend Interchange on error.


    Thanks
    Gyan
    If this answers your question, please mark it as "Answered".
    Wednesday, February 3, 2010 9:11 AM
  • Hi

    Thanks for your reply but I am sure that the validation should happen even if split interchange is selected. Preserve interchange does not parse and disassemble the message. In normal circumstances I receive a EDI file with Interchange control Header and Trailer. In this case the first check should be that whether Biztalk has recieved the file completely or not. I have to select split interchage if I need to do transformation which will parse the message. In this case still the integrity check of the message should be done. I dont think this check should be missing in any case.

    Thanks
    Nikhil
    Wednesday, February 10, 2010 12:52 PM
  • There is some validation settings in the party, can you tell us what you have set up for the EDI party definition.
    Eric Stott [http://blog.biztalk-info.com] - Mark as Answer if this reply does.
    Tuesday, February 16, 2010 11:24 PM
  • Yes, there is validation settings in the party but even on enabling it this problem still continues. Anyway for your information my EDI validation is turned on in the party with Allow leading and trailing zeros and Extended validation.

    Saturday, March 13, 2010 2:19 PM
  • Hi,
        This validation is not covered under edi validation for edi receive pipeline for split interchange. This works only for Preserve Interchange case.


    Thanks
    Gyan
    If this answers your question, please mark it as "Answered".
    Saturday, March 13, 2010 2:47 PM