locked
Url Rewrite with special characters. RRS feed

  • Question

  • User-239902709 posted
    Hi, my url's with special characters opens on helicon isapi-rewrite software.. But when i try with urlrewrite it is not working. what can i do? ex: give 404 not open: http://www.sanalamfi.com/articles/şşşçççööööiiuuuuuiiiiii.html (it is open on helicon isapirewrite) open on urlrewire : http://www.sanalamfi.com/categories/sample-category.html thanks.
    Monday, November 16, 2009 11:12 AM

Answers

  • User-1637866776 posted

    What is the PHP application that you use for this web site? Can you post the rewrite rules?

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Monday, November 16, 2009 1:41 PM
  • User-1637866776 posted

    can you try adding the following PHP code at the beginning of the index.php file:

    if ( isset($_SERVER['UNENCODED_URL']) ) {
      $_SERVER['REQUEST_URI'] = $_SERVER['UNENCODED_URL'];
    }

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Monday, November 16, 2009 8:21 PM

All replies

  • User-1637866776 posted

    What is the PHP application that you use for this web site? Can you post the rewrite rules?

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Monday, November 16, 2009 1:41 PM
  • User-239902709 posted

    webconfig file is:

    <?xml version="1.0" encoding="UTF-8"?>
    <configuration>
     <system.webServer>
      <rewrite>
       <rules>
        <rule name="Imported Rule 1" stopProcessing="true">
         <match url=".*" ignoreCase="false" />
         <conditions>
          <add input="{REQUEST_FILENAME}" matchType="IsFile" ignoreCase="false" negate="true" />
          <add input="{REQUEST_FILENAME}" matchType="IsDirectory" ignoreCase="false" negate="true" />
         </conditions>
         <action type="Rewrite" url="index.php" />
        </rule>
       </rules>
      </rewrite>
     </system.webServer>
    </configuration>

    .htaccess

    # Options:

    # -MultiViews: Turns off multiviews so it doesn't interfer with our rewrite rules

    # -Indexes: Stop directory listings

    # +FollowSymlinks: Let out rewrite rules work

    Options -MultiViews -Indexes +FollowSymlinks

    # Disable any sending of a default character set

    AddDefaultCharset OFF

    # Disable etags -- less headers

    RewriteEngine On

    # RewriteBase /

    <IfModule mod_security.c>

    # Turn off mod_security filtering.

    SecFilterEngine Off

    # The below probably isn't needed, but better safe than sorry.

    SecFilterScanPOST Off

    </IfModule>

    <IfModule mod_deflate.c>

    AddOutputFilterByType DEFLATE application/x-javascript application/javascript text/css text/ html text/xml

    </IfModule>

     

    # PHP is in CGI Mode, so we need a different mod_rewrite

    RewriteCond %{REQUEST_FILENAME} !-f

    RewriteCond %{REQUEST_FILENAME} !-d

    RewriteRule .* index.php [L]

     

    thank you.

    Monday, November 16, 2009 1:47 PM
  • User-239902709 posted

    apache rewrite works on linux and helicon isapi rewrite works on windows check this:

    http://websitepublisher.interspire-demo.com/demo_7852030/iiişçççıııııııöööööüüüü.html

    urlrewrite not working

    http://www.sanalamfi.com/articles/şşşçççööööiiuuuuuiiiiii.html

    i am waiting your reply, thank you.

    Monday, November 16, 2009 7:42 PM
  • User-1637866776 posted

    can you try adding the following PHP code at the beginning of the index.php file:

    if ( isset($_SERVER['UNENCODED_URL']) ) {
      $_SERVER['REQUEST_URI'] = $_SERVER['UNENCODED_URL'];
    }

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Monday, November 16, 2009 8:21 PM
  • User-239902709 posted
    it works thank you.
    Monday, November 16, 2009 8:34 PM