none
Workflows are not automatically triggered in Sharepoint 2007 When an item is added to the list.

    Question

  • Hi,

    I'm pretty much new to SharePoint. Can you please help me to resolve the issue?

    Issue:

    I have created a workflow for adding and modifying the items in the list. I have also checked the check boxes "Automatically start this workflow when a new item is created" . But still my workflow is not triggered. When i started exploring about this issue, I could see some of your threads explaining that "Workflow will not start automatically when items are created by System Account". When I checked the items, I could see those items are created by System Account though the users create the items only through their login. My Question here is, Why the items "created by " shows the System Account though the users use their login to create the items. Is there any configuration , that i should check for this issue?. The same items when modified, displays the user names and the workflows are working fine too.

    Thanks in Advance!

    Thursday, December 08, 2016 6:03 AM

All replies

  • Hi SharmiVinod- sounds like you're having the workflow create/modify items. When you do that, they will always be created/modified by System Account, because that's what the workflow will use.

    If a user creates and item, then it should show the user as the creator, unless the workflow does something to the item before it's saved.


    cameron rautmann

    Thursday, December 08, 2016 6:12 PM
  • Hi Croute1 ,

    Thanks for your response!

    My Workflow does not create/modify items.My workflow should be triggered only on creating/modifying the items. 

    I have an workflow , that should trigger an email when an item is added/modified by the users in the list. Though i have checked on the check boxes for automatically triggering the workflow when an item is created, it does not works as expected. I believe this is because the items "created by" shows System account rather than showing the User Id. When I create an item in the same site, it shows my user id and it also triggers the workflow which works as expected. Also when the items in the list are modified by the users, it shows the column "modified by" as user id and the workflow also gets triggered for modification on items. I'm not sure about any server level configuration that i should check for the reason "Why items created by shows System Account instead of the user id for those users who are actually responsible?". Also I'm not sure about "Why the items created by myself shows my user id?" which is correct. Why the same does not works for other user? I have double checked the permissions in the SharePoint Site for those users and my self which is same. The Permission level for myself and the other users are "Limited Access". 

    Thanks in Advance!
    Friday, December 09, 2016 6:27 AM
  • Any help on this would be appreciated!

    Thanks!

    Tuesday, December 13, 2016 6:27 AM