none
Can't control USB devices RRS feed

  • Question

  • I installed WDK 10 today and had Visual Studio 15 already installed. I am using an oscilloscope than I am communicating with over USB with a C# program. My scope keeps losing communication when it takes too long for some signal acquisitions to occur. I am trying to come up with a way to programmatically disable and re-enable the usb communication to the scope. I found devcon online I it looked like a great fix. The problem is I cannot restart, reset, disable or enable ANY usb devices. I may have missed something in the setup. I'm not sure. Devcon runs without error but it always says it cannot find the device. I have searched for the usb devices on my computer and the scope does show up. Here is the code I am using in command prompt to test this:

    devcon restart "@USB\VID_0699&PID_0368\C020147"

    devcon disable "@USB\VID_0699&PID_0368\C020147"

    devcon enable "@USB\VID_0699&PID_0368\C020147"

    None of these methods work.

    PLEASE HELP!!

    Thanks, DG

    Monday, March 21, 2016 8:50 PM

Answers

  • Thanks for the help. I figured out the problem. Dummy me, I forgot to run devcon as administrator. I set it up to always run that way and now everything works as it should. Thanks!
    Tuesday, March 22, 2016 5:34 PM

All replies

  • Does it lose communication on other Windows versions like Win8.1?

    Have you tried to disable selective suspend in advanced power settings? Win10 seems to squeeze a bit more power savings than is reasonable, even on a desktop type systems. (at least, pre-Redstone versions)

    Your devcon commands do not find the device probably because of crazy command.com syntax. Try powershell instead.  But maybe you won't need it after all.

    -- pa


    • Edited by Pavel A Monday, March 21, 2016 10:26 PM
    Monday, March 21, 2016 10:19 PM
  • what device class is your device showing up as? a HID?

    d -- This posting is provided "AS IS" with no warranties, and confers no rights.

    Tuesday, March 22, 2016 3:41 AM
  • Thanks for the help. I figured out the problem. Dummy me, I forgot to run devcon as administrator. I set it up to always run that way and now everything works as it should. Thanks!
    Tuesday, March 22, 2016 5:34 PM