locked
IIS 8.5 and .NET Framework 4.5 configuration RRS feed

  • Question

  • User413163035 posted

    Searched for the problem that I was getting and could not find any solution so I'm starting this new thread hoping to help those who, like myself, had trouble finding a solution for this problem.

    After more than 3 hours of struggle trying to find a way to solve the 404.17 error code on my IIS 8.5 (on windows 8.1) I found myself the solution for the problem. They say that by default, .NET Framework comes preinstalled on windows 8.1. In fact, on turning windows features on or off panel, the ticker may be misleading. It's true that the 4.5 framework is installed but if you try to run your web applications you'll get stucked with the 404.17 error plus the message that there could be a problem with your web.config file.

    There's no problem at all: all you have to do is to check for the NET framework within the Internet Information Services > World Wide Web Services > Application Development Proccess

    See attached capture just to not go over the trouble I've been.

    Programs and Features can mislead you

    Hope this helps someone.

    Cheers :-)

    Friday, January 3, 2014 11:41 AM

Answers

  • User-1454326058 posted

    Hi j_fradique,

    Thanks for your post!

    According to your description, I would like to know which type of your web application.

    First, please check the .net framework of the web site’s application pool in the IIS.

    Secondly, please try to create a new project and try again.

    BTW: I have installed all Application Development Features and all work fine.

    There is a link may benefit you:

    http://support.microsoft.com/kb/2019689

    Thanks

    Best Regards

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Sunday, January 5, 2014 10:01 PM