none
Custom BAPI is not listing in BAPI/RFC Category in Biztalk adpater wizard RRS feed

  • Question

  • Hi ,

    I am using Biztalk adapter pack and WCF LOB adapter pack to connect to SAP.

    I have created a custom BAPI.If i add adpter service reference in Visual studio it is not finding this BAPI in any of the BAPI /RFC category.All  other standered  BAPIs are listing.

    I am able to access the custom BAPI from SAP front end.But using the adpater pack it is not finding this BAPI.

    Is there any configuration i have to do to list it in BAPI/RFC section in Biztalk Adpater pack UI.

    thanks in advance

    Seena



    Thursday, May 12, 2011 7:35 AM

Answers

  • I saw something like this at a customer who had created a custom BAPI. It appeared in the list but in a weird place. I would try using the search box to try to enter a wildcard search string. For SQL the wildcard is % and I cannot remember if it is % or * for the SAP searches.

    Thanks,


    If this answers your question, please use the "Answer" button to say so | Ben Cline
    Saturday, May 14, 2011 12:35 PM
    Moderator
  • Hi, make sure that the BAPI/RFC is remote enabled.

    In SAP GUI > transaction se37 > Type the RFC name(if it's BAPI, type the mapped RFC name) > Display > Attributes Tab> Remote Enabled Module

    You might have to activate/release the function module for the changes to get reflected.

     

    For seach -- the wild card is "*'(replaces one or more characters ) for SAP.


    Rohit Singh
    Tuesday, May 17, 2011 8:48 AM

All replies

  • I saw something like this at a customer who had created a custom BAPI. It appeared in the list but in a weird place. I would try using the search box to try to enter a wildcard search string. For SQL the wildcard is % and I cannot remember if it is % or * for the SAP searches.

    Thanks,


    If this answers your question, please use the "Answer" button to say so | Ben Cline
    Saturday, May 14, 2011 12:35 PM
    Moderator
  • Hi, make sure that the BAPI/RFC is remote enabled.

    In SAP GUI > transaction se37 > Type the RFC name(if it's BAPI, type the mapped RFC name) > Display > Attributes Tab> Remote Enabled Module

    You might have to activate/release the function module for the changes to get reflected.

     

    For seach -- the wild card is "*'(replaces one or more characters ) for SAP.


    Rohit Singh
    Tuesday, May 17, 2011 8:48 AM