none
Help viewer 2.2 & Annoying Pop UP

    Question

  • hi All Microsoft Super Engineers,

    Do you know how to disable all these pop up ?

    this pop up always shows up every time I click "contents" on the left side. I tried several instructions from this link (http://windows.microsoft.com/en-us/internet-explorer/ie-security-privacy-settings#ie=ie-10) but it works NOTHING .

    this is "Help Viewer 2.2".

    Help viewer 2.2

    TIA

    Tuesday, April 26, 2016 7:59 AM

All replies

  • Hi,

    Which is your Help Preference, Launch in Browser or Launch in Help Viewer?
    If "Launch in Browser" is checked, check "Launch in Help Viewer" and inform whether something would change.


    The below is my case:
      

    Regards.
    Tuesday, April 26, 2016 8:55 AM
  • thx's for your reply but it doesn't work at all.

    the problem still shows up every time I click subject in the left content.

    Rgds,

    Wednesday, April 27, 2016 5:08 AM
  • Hi,

    If an Internet Explorer dialog still appears, after changing to [Launch in Help Viewer] in [Set Help Preference], I'm afraid something corrupted in Visual Studio.

    1. Which edition and version your Visual Studio is?
        

    2. try to run Visual Studio with safe mode.
       input "Devenv.exe /SafeMode" in Run (right click on Start)
       
      Inform how about with Safe Mode.
       

    3. If the issue still persist, 
       3-1. Repair Visual Studio
       3-2. Re-Install Visual Studio

    Regards.
    Wednesday, April 27, 2016 7:14 AM
  • my VS version

    this is screen capture for 'Safe Mode'

    I'm looking spare time to Repair/Re-Install, 

    I'll update the next status.

    Rgds,

    Wednesday, April 27, 2016 8:17 AM
  • Hi SmoothSati,

    Do you have tried repair/reinstall your Visual Studio? Please tell us the result now.

    If the problem still exist, please check your IE version, whether there has any updates for your IE. If yes, please install these updates for your IE first.

    And if repair/reinstall Visual Studio doesn't fix this issue, please use http://aka.ms/vscollect  to gather the VS and .Net Frameowrk installation logs. After using it, you will find vslogs.cab from %temp% folder. Please upload the file to Onedrive and share the link here.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, April 29, 2016 1:20 AM
    Moderator
  • Hi All,

     just finished "repair"

    and then make sure that 'Help Viewer' => 'Launch in the help Viewer'

    What I got on the screen: 

    Same annoying & unwanted 'Pop-up' box.

    when I try directly to run 'Help viewer 2.2', what 'missing parameters' ? This machine is a fresh installation. 

    Working hour GMT+7: 

    start at 10:25PM - 11:28PM (1 hour, 3 Mins), torturing my CPU (75-80%), more electric bill expenses.

    any, solution for these ?

    Rgds,


    • Edited by SmoothSati Friday, April 29, 2016 4:49 PM error
    Friday, April 29, 2016 4:47 PM
  • I've already found this link 

    "Call HelpViewer 2.1 outside Visual Studio 2013" for overcome 'missing parameter' in HelpViewr 2.2 but I still can't resolve why Annoying Pop-Up always shows up.

    Rgds,

    Saturday, April 30, 2016 12:27 AM
  • Hi SmoothSati,

    According to your description and the error message, please try uninstall Help Viewer 2.2 from Control Panel -> Programs and Features -> Help Viewer 2.2 -> Uninstall.

    Then install it with following thread which introduce how to install Help Viewer without install Visual Studio.

    http://stackoverflow.com/questions/27872590/installing-help-viewer-without-installing-visual-studio

    Before installing, please download the Visual Studio ISO installer first from below link, which contains the Help Viewer MSI packages.

    https://www.visualstudio.com/en-us/downloads/download-visual-studio-vs.aspx

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, May 2, 2016 2:53 AM
    Moderator
  • I follow your instruction and...

    Nothing changes, annoying Pop-Up always shows up after I click Content on the right side

    Rgds,


    • Edited by SmoothSati Monday, May 2, 2016 8:54 AM need pict
    Monday, May 2, 2016 8:43 AM
  • Hi SmoothSati,

    According to the pop up message and you have reinstalled the Help Viewer, I think the problem may be related to Internet Explorer.

    Please try open the following links in IE directly, which is the content of .NET Framework 4.6 and 4.5 in Help Viewer.

    https://msdn.microsoft.com/EN-US/library/w0x726c2(v=VS.110,d=hv.2).aspx

    If it can be opened in IE, the problem should still in Visual Studio itself. Please use http://aka.ms/vscollect  to gather the VS and .Net Frameowrk installation logs. After using it, you will find vslogs.cab from %temp% folder. Please upload the file to Onedrive and share the link here.

    If you also get the same prompting message, I'm afraid that the problem is related to IE settings. I suggest you post this problem to IE forum to check whether there has any settings we are missing.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, May 3, 2016 1:37 AM
    Moderator
  • Please try open the following links in IE directly, which is the content of .NET Framework 4.6 and 4.5 in Help Viewer.

    https://msdn.microsoft.com/EN-US/library/w0x726c2(v=VS.110,d=hv.2).aspx

    ^^^ IE 10 can open it, normally.

    If it can be opened in IE, the problem should still in Visual Studio itself. Please use http://aka.ms/vscollect  to gather the VS and .Net Frameowrk installation logs. After using it, you will find vslogs.cab from %temp% folder. Please upload the file to Onedrive and share the link here.

    this is the link: https://onedrive.live.com/redir?resid=884E3FEE08C8AA7D!1772&authkey=!ANfq-Y1W_D_8vcg&ithint=folder%2czip

    Rgds

    Tuesday, May 3, 2016 8:02 AM
  • Hi SmoothSati,

    According to your installation log, there has some errors about failed install some MSI packages. So I'm afraid that you need to reinstall your Visual Studio with following steps.

    Error 0x80070643: Failed to install MSI package.
    Error 0x80070643: Failed to execute MSI package.
    Error 0x80070643: Failed to configure per-machine MSI package.

    1. Uninstall Visual Studio from Control Panel -> Programs and Features -> Visual Studio 2015 -> Change -> Uninstall.
    2. Uninstall all Visual Studio related components with msiinv tool, which will list all
      installed msi on your OS. Then try the msiexec /x <product code> to remove that component if it is related to Visual Studio. Please refer to this blog.
    3. Download Visual Studio Community 2015 ISO installer from this link.
    4. Please use FCIV.exe http://support.microsoft.com/kb/841290 to verify hash of the ISO. The sha1 value of ISO, please refer to: https://www.visualstudio.com/en-us/downloads/visual-studio-2015-iso-sha1-vs.aspx
    5. Install Visual Studio with the correct ISO installer.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.


    Wednesday, May 4, 2016 2:07 AM
    Moderator
  • Error 0x80070643: Failed to install MSI package.
    Error 0x80070643: Failed to execute MSI package.
    Error 0x80070643: Failed to configure per-machine MSI package.

    can I install this MSI packages without a whole bunch of 8GigB installation for hours ?

    without knowing "Failed MSI packages", I have to install VS, again ? What a reasons ?



    • Edited by SmoothSati Wednesday, May 4, 2016 4:09 AM aaa
    Wednesday, May 4, 2016 3:20 AM
  • Hi SmoothSati,

    After re-reading your previous replies, I find that you are using IE 10. In my opinion, IE 11 has the best compatibility with Visual Studio 2015. There has many communities has problem use previous version IE in Visual Studio 2015 before. So I suggest you upgrade your IE to version 11 to check whether this problem caused by the IE version.

    And then set the IE 11 settings with the guidance from the link in your original post.

    If the problem still exist, please remove all downloaded content in your Help Viewer and then download them with this Help Downloader tools to import the help content into Help Viewer. It can help us confirm whether it is caused by the content itself.

    In addition, could you please tell us which version of Windows do you use? Since my colleague has the similar problem on a Windows Server machine before. I need to confirm whether this problem is related to Windows version.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, May 5, 2016 6:03 AM
    Moderator
  • The main issue for this "Pop-Up" is the MIME sniffing (gpedit.msc): 

    "Local Computer Policy", drill down to the following entry: Computer Configuration / Administrative Templates / Windows Components / Internet Explorer / Internet Control Panel / Security Page / Internet Zone

    if MIME enable then "Pop-Up" always shows

    if MIME disable/inactive then help view contain raw HTML.

    this is my original IE:

    • Edited by SmoothSati Friday, May 6, 2016 4:49 PM 123
    Friday, May 6, 2016 2:57 PM
  • Hi SmoothSati,

    According to your prompt, I checked my MIME sniffing setting. I found that in my settings I neither set it as enable, nor set it as disable. It is set as "Not Configured". Please set as Not Configured to check whether the problem can be fixed.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, May 9, 2016 1:58 AM
    Moderator