none
WFM 1.0 installation messed up? RRS feed

  • Question

  • Installed Work Flow Manager 1.0 via web platform installer. Running Windows 7 with VS2013 Update 4. Tried to do the tutorial. HttpSend activity not available in toolbox. Tried to browse for it. Went to Microsoft.Activities.dll. Loaded it (and other activites) into the Choose Toolbox Items dialog. Click ok. Receive message " The following tools were successfully added to the toolbox but are not enabled in the active designer. Thus, the HttpSend activity won't go into the tool box and cannot complete the tutorial. 

    Next, thought maybe the installation was incorrect. tried re-running installer for Workflow Manager Tools. I get: "Microsoft Web Platform Installer couldn't find the product you tried to install. Either the link you clicked is incorrect or you may be overriding your feed with a different feed." Then there is a link to learn more about custom feeds and how to reset Microsoft Web Platform Installer, click here. When I click that i am taken to a promotional page titled Microsoft/web that is advertising WebMatrix3 for downloadit and other web products. To me, this is a non-sequitur and does not answer my issue.

    So I try uninstalling it all. Removed  WF farm and SB farm, ran uninstaller, removed databases, etc. Uninstall Workflow Fabric. Uninstall Service Bus. Looks like nothing more to uninstall.

    Went into VS2013 thinking to remove any Extensions. Saw Work Flow Manager Activites. But its uninstall button is greyed out and it says I must use Programs and Features pane in Windows Control Panel to uninstall it. I look at Programs and Features pane -  there is nothing related to workflow or activities listed anymore.

    So I try again to install work flow manager tools. Web Platform Installer still says it can't find the program. Tried installing Workflow Client - WPI says it is already installed. I thought I had uninstalled it. 

    I am very confused by all this and would appreciate any help, advice, or prior experience anyone can offer - all I want to do is be able to install Workflow Manager and do the tutorials. Thanks in advance.

    Thursday, February 12, 2015 3:39 PM