locked
Unable to access publisher portal or developer portal RRS feed

  • Question

  • I am unable to access the Developer Portal or the Admin/Publisher Portal associated with my API Management instance.  According to the Azure Portal, the status of my API Management instance is listed as "Ready".  According to the Azure Service Dashboard, API Management is "All good" and there's a green check in the API Management column.

    This has been working fine for the past few days, but so far today (EST) those portals are unavailable.  Shouldn't I see some indication of a problem on both the Azure Portal and the Service Dashboard?

    For reference, here's a link to my developer portal:
    https://blackbaudcrm.portal.azure-api.net


    Wednesday, October 15, 2014 5:39 PM

Answers

  • Hi Ben, your service is currently undergoing an upgrade. It should be back in a couple of hours.
    • Marked as answer by Ben Lambert Tuesday, October 21, 2014 8:01 PM
    Wednesday, October 15, 2014 6:29 PM

All replies

  • Thanks for letting us know, we'll investigate.
    Wednesday, October 15, 2014 6:22 PM
  • We are experiencing the same issues with one of our subscription (both in same region).  Portal is not reachable in one subscription but is in the other.  This stopped working at exactly 3 AM CDT.

    Wednesday, October 15, 2014 6:23 PM
  • Hi Ben, your service is currently undergoing an upgrade. It should be back in a couple of hours.
    • Marked as answer by Ben Lambert Tuesday, October 21, 2014 8:01 PM
    Wednesday, October 15, 2014 6:29 PM
  • Can you please let me know your service name ?
    Wednesday, October 15, 2014 6:30 PM
  • EDIT:  My API Management instance name is "blackbaudcrm"

    Hi MiaoJiang - my service name is BLREx-svc.

    Should I see an indication that my service is being upgraded somewhere?


    • Edited by Ben Lambert Wednesday, October 15, 2014 6:35 PM
    Wednesday, October 15, 2014 6:34 PM
  • Is an 'upgrade' a normal thing?  We just recently went live with this and did not have issues with another subscription we've been testing with for months.  If this is normal then we're dropping the interface.


    • Edited by Andy Gould Thursday, October 16, 2014 12:54 PM
    Wednesday, October 15, 2014 6:43 PM
  • Hi Andy, this is not a normal thing and does not happen often.

    Also, if you are looking for high availability, please consider upgrading to the Standard tier.

    Wednesday, October 15, 2014 9:55 PM
  • Thanks for the reply and yes, we're definitely looking at moving to the Standard tier if we move forward with the implementation.
    Thursday, October 16, 2014 12:54 PM
  • Great, let us know if you have any questions down the road.
    Thursday, October 16, 2014 9:52 PM
  • thanks MiaoJiang - my portals are accessible now, so it looks like the upgrade was successful.

    I'm fine with the disruption on my end given that this is the Developer Tier and I'm currently just exploring API Management, but shouldn't I see some indication of the portal status being "unavailable" in my Azure console or the APIM developer portal?  And shouldn't there be some visual indicator that my site is in the process of being upgraded?  

    If there is a location where this status is visible, I would have been able to see it and realize what was happening and not have to submit a question.  Let me know if I just missed it somewhere.

    Thanks again for the help!
    Friday, October 17, 2014 4:13 AM