none
Problem creating a New Linked Service in Azure Data Factory

    Question

  • Hi,

    I'm trying to create a new linked service in Azure Data Factory.

    1- "Microsoft Integration Runtime" is already installed and with succesfull test in "Diagnostics" with ODBC to an Oracle 11g 64-bit Database. The connection test resulted sucessfully.

    2- In AzureDataFactory, in the Integration Runtimes the type is "Self-Hosted" and the status is "Running".

    With this, I'm trying to say that I think everything is OK from the on-premise point of view.

    However, when I try to create a new linked service, I choose "ODBC", once I fill the form, and I push in test connection I get the following error:

    Connection failed

    Error: Response with status: 404 not found for URL: https://s2.datafactory.ext.azure.com/api/V2query2/EncryptData

    I don't know what to do.

    -----

    The purporse is the copy data from an Oracle DB on-premise to the cloud. I have already installed Oracle Client 11g 64 bit. I have already configured ODBC 64-bits in Windows. I have already installed Microsoft Integration Runtime. In the Microsoft Integration Runtime Configuration Manager, it is connected to the cloud, in the downside of the window there is a Green Check and it says "Connected to the cloud Service (Data Factory V2). In the home it says "Self-hosted node is connected to the cloud service". In the Diagnostics I tested an ODBC connection, and it resulted ok.

    Thanks !

    Roberto E.

    Friday, August 10, 2018 4:22 PM

All replies

  • Hi,

    I did the same steps but with ADF V1 and everything worked OK. Therefore, I think it should be a problem with Azure.

    Thanks !

    Roberto E.

    Friday, August 10, 2018 11:05 PM
  • Hi Roberto,

    ADF currently has a built in Oracle connector. Would you please go and have a try with oracle connector?

    Thanks. 

    Saturday, August 11, 2018 2:55 AM
  • What is your data factory region?
    Saturday, August 11, 2018 6:56 AM
  • For ADF V2: West US 2

    For ADF V1: West US

    Saturday, August 11, 2018 1:06 PM
  • Hi Wang,

    Let me try it. It worked perfect in ADF V1, now I will reconfigure the Microsoft Integration Runtime.

    Sorry for this, but I read I can ask for my account to be verified. COuld you help me with that ? Or you are not the person ?

    Thanks

    Roberto E.

    Saturday, August 11, 2018 1:23 PM
  • Hi Wang,

    With Oracle in ADF V2 it happens the same:

    Connection failed
    Error: Response with status: 404 Not Found for URL: https://s2.datafactory.ext.azure.com/api/V2query2/EncryptData

    Thanks

    Roberto E.

    PD: I would like to upload images, but i can't.


    Saturday, August 11, 2018 1:40 PM
  • I changed my ADF V2 to West US (creating a new one) and It worked ! There should be a problem with West US 2.

    Thanks

    Roberto E.

    Saturday, August 11, 2018 2:03 PM
  • We have fixed this issue for west us2. Thanks for reporting this.
    Wednesday, August 15, 2018 4:23 AM
  • Thanks to you.

    Saturday, August 18, 2018 1:55 PM
  • HI Robert,Can you share the steps you followed for migrating Oracle(On Prem) to Sql Server(Cloud). Any migration tool required for this .Please share the steps.
    Friday, October 5, 2018 9:53 AM
  • @hello_azure

    You could use azure data factory. 

    It supports oracle as source and azure sql as sink. 

    https://docs.microsoft.com/en-us/azure/data-factory/connector-oracle

    https://docs.microsoft.com/en-us/azure/data-factory/connector-azure-sql-database


    Tuesday, October 9, 2018 3:37 AM