none
Azure Storage: Tables issue with Visual Studio Template

    Question

  • Hi,

    I am having an issue with the "Azure Storage: Tables" quickstart in Visual Studion 2013 Community. I have installed Azure SDK for VS 2013 (V2.6). Anyway, once I create a new app based on this template a few things happen.

    The references: "Microsoft.WindowsAzure.Configuration" and "Microsoft.WindowsAzure.Storage" are unresolved. These come with the project and its references
    are pointed to there. So it resolves at build.

    However I get a runtime error complaining about the following:
    Could not load file or assembly 'Microsoft.Data.OData, Version=5.6.2.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

    So this seems to now work the way it should.

    If I create a new project.

    "Microsoft.WindowsAzure.Configuration" and "Microsoft.WindowsAzure.Storage" and "Microsoft.Data.OData" are not avaliable a new references.

    Questions:

    1. So is they some post-configuration tasks I am meant to do after installing the Azure SDK?
    2. Are these options meant to be avalible in the general reference list (when I try to add a new reference).

    3. How should I fix the issue with the Microsoft.Data.OData error.

    Also just so I know is this also the correct forum for these development issues with Azure?

    Thanks,

    Ward.


    • Edited by WardH Friday, May 22, 2015 6:11 AM
    Friday, May 22, 2015 6:06 AM

Answers

All replies