none
Unable to install .NET 4 Framework redist using winrs RRS feed

  • Question

  • I’m working to deploy .Net 4.0 Framework in a distributed system with Windows 2008 Server R2 using winrs.

    To execute the update on systems we use WINRS with a defined account that has administrator privileges i.e.

                    winrs –r:remotesys1 –u:admin1 –p:admin1passwd ….

    What we have found is that the .Net 4.0 framework fails to install on the remote system with a access denied error below.

    Launching CreateProcess with command line = wusa.exe "R:\34ba719cabadb5167918438cf2\Windows6.1-KB958488-v6001-x64.msu" /quiet /norestart
    [8/24/2011, 13:51:7]Exe (R:\34ba719cabadb5167918438cf2\Windows6.1-KB958488-v6001-x64.msu) failed with 0x5 - Access is denied. .


    I have found that using winrs to call the .msu update directly fails w/ the same error even when using a login account with administrator privileges:

    winrs  –r:remotesys1  –u:admin1  –p:admin1passwd  wusa.exe c:\update.msu  /quiet /norestart

     

    I have tried various solutions listed on the web from subinacl changes to deleting the \SoftwareDistribution folder.

    I know that the .Net 4.0 framework install does work as expected when I’m logged into the remote system with no issues.

     

    Is it possible to use winrs with wusa to install .msu remotely and if so what is the command or steps needed to make it work?

    Or is there another way to deploy .Net 4.0 Framework on remote distributed systems as part of a unattended install?

     

    I can send you install logs, if you like.  I don't see an option for attaching a file to a post.

     

    Thanks for the help and/or any suggestions that you have.

    Monday, August 29, 2011 8:47 PM

Answers

  • Finally figured this out.  WinRM does impose memory limits on WinRS consoles.  With the quick configuration settings, this limits WinRS consoles to 150MB per console including child processes.  The processes I was running together with the .NET installation hit the 150MB quota and caused the error.  Adjusting the limit to 1GB fixed this issue by using the command,

    winrm set winrm/config/winrs @{MaxMemoryPerShellMB="1024"}

    See this blog entry and corresponding ServerFault question for more information.

    • Marked as answer by NullMan Thursday, July 19, 2012 9:53 PM
    Thursday, July 19, 2012 9:53 PM

All replies