locked
Unable to use Microsoft.VisualStudio.XmlEditor.dll in different versions RRS feed

  • Question

  • I am using Microsoft.VisualStudio.XmlEditor.dll for creating xml designer page in custom project. Initially I have created VS package for my custom project for 2012 using 2012 version of Microsoft.VisualStudio.XmlEditor.dll and my template works fine. Then I tried to make my VSIX compatible with VS 2013, VS 2015. As expected,  VSIX installed successfully but when i tried to open xml designer page, I am getting the below error.

    Error was not thrown when I create separate projects for 2012, 2013, 2015 and refer Microsoft.VisualStudio.XmlEditor.dll of those versions separately. But it leads to maintaining 3 vsix for my project.

    Any solution for this?

    Regards,

    Samsudeen K s


    Thursday, July 9, 2015 12:03 PM

Answers