none
Project Server 2010 DM Dynamic Workflow- Deployment problem? RRS feed

  • Question

  • Hi,

    I am having problems deploying Dynamic Workflow in Project Server 2010. I tried to deploy it using these steps:

    http://social.technet.microsoft.com/Forums/en-US/projserv2010setup/thread/82cefbc5-9b50-4753-92d1-9466c2f30f50

    And when I "Run as administrator" the cmd file, I get this error:

    "The argument '.\Deploy.ps1' to the -File parameter does not exist. Provide the path to an existing '.ps1' file as an argument to the -File parameter."


    I tried to change the path to script from .\Deploy.ps1 to "\path....\Deploy.ps1" and then I got this error

    Deactivating feature: DMDynamicWorkflow_DynamicWorkflow - Done.
    Rectracting solution: DMDynamicWorkflow.wsp - Done.
    Removing solution: DMDynamicWorkflow.wsp - Done.
    
    Adding solution: DMDynamicWorkflow.wspAdd-SPSolution : ./DMDynamicWorkflow.wsp:
    The specified file was not found.
    At C:\Users\sharepoint\Desktop\DynamicWorkflow\DynamicWorkflow\DeploymentFiles\
    Deploy.ps1:63 char:19
    +     Add-SPSolution <<<<  $SolutionPath | Out-Null
        + CategoryInfo          : InvalidData: (Microsoft.Share...dletAddSolution:
       SPCmdletAddSolution) [Add-SPSolution], FileNotFoundException
        + FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletAddSolut
       ion
    
     - Done.
    Deploying solution: DMDynamicWorkflow.wspInstall-SPSolution : Cannot find an SPS
    olution object with Id or Name: DMDynami
    cWorkflow.wsp.
    At C:\Users\sharepoint\Desktop\DynamicWorkflow\DynamicWorkflow\DeploymentFiles\
    Deploy.ps1:74 char:27
    +         Install-SPSolution <<<<  $SolutionName -GACDeployment -Confirm:$false
        + CategoryInfo          : InvalidData: (Microsoft.Share...InstallSolution:
       SPCmdletInstallSolution) [Install-SPSolution], SPCmdletPipeBindException
        + FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletInstallS
       olution
    
     - Done.
    Activate feature: DMDynamicWorkflow_DynamicWorkflowEnable-SPFeature : The Featur
    e is not a Farm Level Feature and is not found in
    a Site level defined by the Url http://project-server:100/PWA/.
    At C:\Users\sharepoint\Desktop\DynamicWorkflow\DynamicWorkflow\DeploymentFiles\
    Deploy.ps1:85 char:25
    +         Enable-SPFeature <<<<  $FeatureName -Url $SiteUrl
        + CategoryInfo          : InvalidData: (Microsoft.Share...etEnableFeature:
       SPCmdletEnableFeature) [Enable-SPFeature], SPCmdletException
        + FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletEnableFe
       ature
    
     - Done.
    Finish
    Press any key to continue . . .
    


    Does anybody have a clue why is this happening?

    Thank you all for help

    Sunday, May 26, 2013 12:43 PM

Answers