KinectSensorChooser does not exist? RRS feed

  • Question

  • Hi! :)

    I'm new to this forum and new to Kinect C# in general, so my apologies if this has been asked before.

    I'm currently following the MDSN Channel 9 Kinect Quickstart series and working on the skeletal tracking section with the smiley and two circles. I believe I've got the code down but I have 5 errors, all relating to "KinectSensorChooser1". 4 of them are in the .cs window and are all "the name 'kinectSensorChooser1' does not exist in the current context', and 1 is in the .xaml file and says 'The type 'my:KinectSensorChooser' was not found. Verify that you are not missing an assembly reference and that all referenced assemblies have been built."

    The strange thing is, I downloaded the Quickstart samples and tried to run their version of the Skeleton Tracker on my computer, but it came out with errors as well, regarding the KinectSensorChooser and a KinectColorViewer.

    Would it be more convenient if I posted my whole code on here? Any help and guidance would be greatly appreciated!

    Friday, February 15, 2013 6:38 PM

All replies

  • Anyone, please? Any pointer in any direction would be helpful :)
    Saturday, February 16, 2013 1:07 AM
  • what version of the SDK do you have installed?
    Saturday, February 16, 2013 1:26 AM
  • Version 1.6
    Saturday, February 16, 2013 1:35 AM
  • can you run and compile the Kinect Explorer - WPF sample from the Toolkit?
    Saturday, February 16, 2013 1:46 AM
  • The console says something to the effect of "Status: connected" and the window pops up. It's all grey though.. there are settings such as the ColorStream and changing them just changes the grey to a different shade. Is that normal? :P
    Saturday, February 16, 2013 1:55 AM
  • well, it would depend on what the sensor is aimed at, but you should be seeing an RGB and depth stream in the app. The console is using KinectSensorChooser, so you have it installed correctly. Not sure about the code you are trying to use from Channel 9, it might have been based on older versions of the SDK and need a port to newer version.

    Do any of the Toolkit samples work and show color/depth/Skeletal?

    Saturday, February 16, 2013 2:13 AM
  • The KinectExplorer does have some options, but changing them just changes the shade of grey it displays. I tried the other samples and they either turn up a blank screen or a black screen - just a solid color, no images. The videos I'm following on Channel 9 were posted in February of 2012. How would you go about porting them to the newer version, if needed?

    Another strange thing is that as I'm running the sample apps, the three sensors aren't emitting any lasers or lights, except for the green light that shows me the Kinect is on. Not sure if this has to do with anything?

    Saturday, February 16, 2013 2:51 AM
  • Three sensors?
    Saturday, February 16, 2013 3:37 AM
  • Sorry. :) I mean the cameras and the infrared projector on the one sensor.
    Saturday, February 16, 2013 9:14 PM
  • Problem solved over the weekend. It had to do with faulty default reference additions in Visual Studio that I deleted and then re-added. Thanks Todd! :)

    Monday, February 18, 2013 3:36 AM
  • Good to hear!
    Monday, February 18, 2013 2:28 PM
  • Problem solved over the weekend. It had to do with faulty default reference additions in Visual Studio that I deleted and then re-added. Thanks Todd! :)

     what was that faulty default reference which you deleted? 

    Would you please describe how?

    Saturday, June 29, 2013 7:53 PM