locked
Printer with device emulator RRS feed

  • Question

  • Hi all

    I am trying to run eVC++ 4.0 .exe from WCE Device emulator  5.0. I want to execute an .exe which has some printer mechanism from emulator but it does not detect the default printer in print Setup dialog box when the PrintSetupDlg() executes.

    please help

    Regards Param

    Wednesday, June 30, 2010 9:31 AM

Answers

  • I would say there's no way for you to print on the printer connected to the PC. You might configure your printer on the emulator (assuming OS includes that capability) and redirect output to a mapped serial port on the PC. Then you can hook up actual printer to that port or attach terminal emulator to capture the output.

    This posting is provided "AS IS" with no warranties, and confers no rights.
    Wednesday, June 30, 2010 4:39 PM
    Moderator

All replies

  • I would say there's no way for you to print on the printer connected to the PC. You might configure your printer on the emulator (assuming OS includes that capability) and redirect output to a mapped serial port on the PC. Then you can hook up actual printer to that port or attach terminal emulator to capture the output.

    This posting is provided "AS IS" with no warranties, and confers no rights.
    Wednesday, June 30, 2010 4:39 PM
    Moderator
  • Thanks Ilya Tumanov for your reply,

    Actually i don't have the device. just the WCE emulator 5.0 and i am running my application on WCE emulator which is in eVC++ but it does not show the Page Setup Dialog Box on executing PageSetupDlg(). It always returns 0. I am new...Please help.

     

     

    Regards Param

    Thursday, July 1, 2010 10:42 AM
  • Yes, my answer above is for that very case. If emulator does not show printer setup box then probably OS in the emulator does not support it.
    This posting is provided "AS IS" with no warranties, and confers no rights.
    Thursday, July 1, 2010 3:45 PM
    Moderator
  • Thanks Ilya Tumanov

    Yes, you are right , OS in the emulator does not supporting the printer.

    one thing more, two days before i was running my application, At that time PageSetupDlg() returns 0x1008 ( means default printer does not exist) after that i have installed printer on my OS but then it returns 0. Now i have uninstalled all the printers but still it returns 0. I want my application atleast return 0x1008. I am confused....pls help.

    Thank You very much for your kind response......

    Regards param

    Friday, July 2, 2010 8:14 AM
  • Yes.......The problem has been solved.....Now my application on emulator showing the error : 0x1008....

    Thanks for your kind response.....

    Regards Param 

    Monday, July 5, 2010 7:45 AM