none
Error building CE7 os image RRS feed

  • Question

  • I have been trying to build a CE7 image but everytime I try to run Sysgen I get the following errors:

    Res2Exe: Info: Res2Exe: ERROR: WriteResFile: did not find IMAGE_DOS_SIGNATURE in old exe header.

    Res2Exe: ERROR: WriteResFile: did not find IMAGE_DOS_SIGNATURE in old exe header.Res2Exe:

    ERROR: EndUpdateResource failed, GetLastError = 191.

    Res2Exe: ERROR: EndUpdateResource failed, GetLastError = 191.

    Res2Exe: ERROR: Error adding resources to target (191).

    Res2Exe: ERROR: Error adding resources to target (191).

    makeimg: FATAL ERROR: Command returned non-zero exit code 1 (dec).

    makeimg: FATAL ERROR: Command returned non-zero exit code 1 (dec).

    The system cannot find the file specified.

    BLDDEMO: ERROR: Error(s) in makeimg phase. See C:\WINCE700\build.log for details.

    BLDDEMO: BUILDMSG: BldDemo ended at 16:34:48.66 on Mon 08/05/2013 (exit code 1)

    BuildLogs: BUILDMSG: Exiting: BldDemo1.bat  -qbsp (result code 1).

    BuildLogs: BUILDMSG: C:\WINCE700\build.logBuildLogs: BUILDMSG: C:\WINCE700\build.

    outBuildLogs: BUILDMSG: C:\WINCE700\build.

    wrnBuildLogs: BUILDMSG: C:\WINCE700\build.err

    and the error log shows this:
    Res2Exe: ERROR: WriteResFile: did not find IMAGE_DOS_SIGNATURE in old exe header. {log="C:\WINCE700\build.log(2258)"}
    Res2Exe: ERROR: EndUpdateResource failed, GetLastError = 191. {log="C:\WINCE700\build.log(2259)"}
    Res2Exe: ERROR: EndUpdateResource failed, GetLastError = 191. {log="C:\WINCE700\build.log(2260)"}
    Res2Exe: ERROR: Error adding resources to target (191). {log="C:\WINCE700\build.log(2261)"}
    Res2Exe: ERROR: Error adding resources to target (191). {log="C:\WINCE700\build.log(2262)"}
    makeimg: FATAL ERROR: Command returned non-zero exit code 1 (dec). {log="C:\WINCE700\build.log(2263)"}
    makeimg: FATAL ERROR: Command returned non-zero exit code 1 (dec). {log="C:\WINCE700\build.log(2264)"}
    BLDDEMO: ERROR: Error(s) in makeimg phase. See C:\WINCE700\build.log for details. {log="C:\WINCE700\build.log(2266)"}

    Do yall have any idea what cold be the issue? I have searched all over and cant seem to get anywhere

     

     

     

     

     


    Matthew


    • Edited by mdb17 Monday, August 5, 2013 9:49 PM
    Monday, August 5, 2013 9:47 PM

Answers

  • I was able to fix the error buy reinstalling Platform builder

    Matthew

    • Marked as answer by mdb17 Wednesday, August 7, 2013 3:14 PM
    Wednesday, August 7, 2013 3:14 PM

All replies

  • It might help if we knew which res file.


    Bruce Eitman (eMVP)
    Senior Engineer
    Bruce.Eitman AT Eurotech DOT com
    My BLOG http://geekswithblogs.net/bruceeitman

    Eurotech Inc.
    www.Eurotech.com

    Tuesday, August 6, 2013 1:18 PM
    Moderator
  • whoops, sorry does this help?

    makeimg: run command: res2exe -r -c C:\WINCE700\OSDesigns\VTS_eBox_CE7\VTS_eBox_CE7\RelDir\ICOP_EBOX3310A_70D_x86_Release\0409\httpd.res C:\WINCE700\OSDesigns\VTS_eBox_CE7\VTS_eBox_CE7\RelDir\ICOP_EBOX3310A_70D_x86_Release\httpd.dll
    Res2Exe: Info: makeimg: Localizing files listed in C:\WINCE700\OSDesigns\VTS_eBox_CE7\VTS_eBox_CE7\RelDir\ICOP_EBOX3310A_70D_x86_Release\shell.loc
    makeimg: run command: res2exe -r -c C:\WINCE700\OSDesigns\VTS_eBox_CE7\VTS_eBox_CE7\RelDir\ICOP_EBOX3310A_70D_x86_Release\0409\ceshell.res C:\WINCE700\OSDesigns\VTS_eBox_CE7\VTS_eBox_CE7\RelDir\ICOP_EBOX3310A_70D_x86_Release\ceshell.dll
    Res2Exe: Info: makeimg: run command: res2exe -r -c C:\WINCE700\OSDesigns\VTS_eBox_CE7\VTS_eBox_CE7\RelDir\ICOP_EBOX3310A_70D_x86_Release\0409\explorer.res C:\WINCE700\OSDesigns\VTS_eBox_CE7\VTS_eBox_CE7\RelDir\ICOP_EBOX3310A_70D_x86_Release\explorer.exe
    Res2Exe: Info: makeimg: Localizing files listed in C:\WINCE700\OSDesigns\VTS_eBox_CE7\VTS_eBox_CE7\RelDir\ICOP_EBOX3310A_70D_x86_Release\wceshellfe.loc
    makeimg: run command: res2exe -r -c C:\WINCE700\OSDesigns\VTS_eBox_CE7\VTS_eBox_CE7\RelDir\ICOP_EBOX3310A_70D_x86_Release\0409\control.res C:\WINCE700\OSDesigns\VTS_eBox_CE7\VTS_eBox_CE7\RelDir\ICOP_EBOX3310A_70D_x86_Release\control.exe
    Res2Exe: Info: makeimg: run command: res2exe -r -c C:\WINCE700\OSDesigns\VTS_eBox_CE7\VTS_eBox_CE7\RelDir\ICOP_EBOX3310A_70D_x86_Release\0409\cplmain.res C:\WINCE700\OSDesigns\VTS_eBox_CE7\VTS_eBox_CE7\RelDir\ICOP_EBOX3310A_70D_x86_Release\cplmain.cpl
    Res2Exe: Info: makeimg: run command: res2exe -r -c C:\WINCE700\OSDesigns\VTS_eBox_CE7\VTS_eBox_CE7\RelDir\ICOP_EBOX3310A_70D_x86_Release\0409\connpnl.res C:\WINCE700\OSDesigns\VTS_eBox_CE7\VTS_eBox_CE7\RelDir\ICOP_EBOX3310A_70D_x86_Release\connpnl.cpl
    Res2Exe: Info: makeimg: run command: res2exe -r -c C:\WINCE700\OSDesigns\VTS_eBox_CE7\VTS_eBox_CE7\RelDir\ICOP_EBOX3310A_70D_x86_Release\0409\intll.res C:\WINCE700\OSDesigns\VTS_eBox_CE7\VTS_eBox_CE7\RelDir\ICOP_EBOX3310A_70D_x86_Release\intll.cpl


    Matthew

    Tuesday, August 6, 2013 1:23 PM
  • I was able to fix the error buy reinstalling Platform builder

    Matthew

    • Marked as answer by mdb17 Wednesday, August 7, 2013 3:14 PM
    Wednesday, August 7, 2013 3:14 PM