SOLVED No RDP Connection after changing of the WE7 ComputerName


  • Hello.

    I encounter problems with RDP connection that are probably related to FBWF. A friend of mine has pointed out that it may be connected with the RegisteryFilter however I have not worked with it before.
    Both FBWF and RegFilter are included in the WindowsEmbedded Standard 7 Image, that is being deployed.

    The Problem is, that after I change the ComputerName I cannot connect any more to the WE7 through RDP. 
    If the computer stays with its name since its deploy, the RDP connection remains intact.

    After the change, when the FBWF is enabled, I cannot connect trough the RDP.
    After change of the Computer Name, I can connect to the EmbeddedPC only during the following single boot of the device.

    In the list below I try to illustrate the case. Each point represents a single boot.

    1. FBWF ON -> RDP ok -> reboot (switch off fbwf)
    2. FBWF OFF -> RDP ok -> Change Computer Name -> reboot (switch on fbwf)
    3. FBWF ON -> RDP ok -> reboot
    4. FBWF ON -> no RDP

    Also, what may be connected with the case: when the write filter is enabled and the device is being rebooted. During Startup the Windows Error Recovery dialog appears:
    "Windows failed to start". The default option "Start Windows normally" time-outs after 30 seconds and the system boots without further errors.

    How could the change of Computer Name possibly influence a remote desktop connection in a Windows Embedded Standard 7?

    I have examined the logs for the Client, where FROM I am trying to connect. The two known error codes that I managed to find are 8199 and 2308.
    The error message on the client side says: "This computer can't connect to the remote computer."
    On the host side I do not get any errors! The EventLog contains Information about incoming RDP-Tcp packets.

    Thank You.

    EDIT: For further issues, i have managed to discover the probable reason of the problem:

    The ComputerName is changed during next boot, which means: if I have changed it and switched on the FBWF, the  filter will forbid the ComputerName change, or at least it will be 'volatile' like.

    Therefore, i could connect only once (on next boot) because the cache of my client computer did used the old 'computerName'. (The certificate did have an old name).

    The SOLUTION is: Reboot your computer once without switching the FBWF after you changed the computerName. 

    I even managed to do it in two steps:

    1. FBWF ON -> Change computer Name -> reboot (switch off fbwf)
    2. FBWF OFF -> reboot (switch on fbwf)

    • Edited by Rafq77 Monday, March 17, 2014 11:32 AM SOLVED
    Friday, March 14, 2014 3:08 PM