locked
Internet Explorer Error when I run a page in Visual Studio 2008 Team System RRS feed

  • Question

  • User1250812075 posted

    Hello All,

    I am using visual studio 2008 team system to test web application on Windows Vista Home Premium. I am unable to see the compiled pages in vs built in web server. I get "Internet explorer cannot display webpage" error whenever i run any of the web site which i want to test. For the solution i followed the following steps
    1. I reinstall asp.net by using the following command
    windir%\microsoft.net\framework\v2.0.50727\aspnet_regiis.exe -u
    %windir%\microsoft.net\framework\v2.0.50727\aspnet_regiis.exe -i -enable
    2. i edited c:\windows\system32\drivers\etc\hosts file by commenting #::1 localhost and :::1 localhost and I also tried by completely removing the two lines.
    3. I stopped windows firewall
    4. I stopped avast antivirus
    But still i am not able to solve the problem
    
    
    Can any buddy tell me the solution.
    
    
    Best regards

    Sunday, March 7, 2010 7:14 AM

All replies

  • User-1618234021 posted

    AOA Ghaffar

    Sometimes this is an issue due to the antivirus that blocks some ports and thus your server can not use those ports. See the following link, it might help you.

    http://forums.asp.net/t/987980.aspx


    Sunday, March 7, 2010 8:53 AM
  • User-37275327 posted

    Check for any messengers  (Skype, Yahoo etc ) working around. Disable and re register IIS with asp.net.


    Sunday, March 7, 2010 11:02 AM
  • User1250812075 posted

    WAS Ehsan,

    Thanks for your reply. Well i uninstalled avast antivirus and still problem persists. 

    Sunday, March 7, 2010 10:23 PM
  • User-37275327 posted

    Try using the internal browser rather than IE. To change to setting File>Browse With>Internal Web browser/


    Monday, March 8, 2010 12:52 AM
  • User1070358828 posted

    Try to open your page in other browser like (Mozilla FireFox)

    Monday, March 8, 2010 1:32 AM
  • User1250812075 posted

    Thanks Singhe for your reply.

    I tried to browse with internal broswer, google chrome, ie, firefox but no luck so far.

    Monday, March 8, 2010 2:35 AM
  • User1070358828 posted

    Try to reset settings of your visual studio 2008 Team System as follwing

    go to the visual studio comand prompt and write this command

    Devenv /ResetSettings

    try it and let us see what will happend 

    good luck


    Monday, March 8, 2010 3:37 AM
  • User1250812075 posted

    Dear Sir,

    Thank you very much for your reply i tried by resetting vs 2008 but no luck so far.

    Monday, March 8, 2010 4:11 AM
  • User1250812075 posted

    I also tried to recreate "http://support.microsoft.com/kb/972034" host file but still no luck .

    Monday, March 8, 2010 5:44 AM
  • User-1011786642 posted

    After you try to open the page can you check the "Application" event log? Are there any errors?

    Monday, March 8, 2010 5:50 AM
  • User1250812075 posted

    Event code: 3008
    Event message: A configuration error has occurred.
    Event time: 3/8/2010 3:41:54 PM
    Event time (UTC): 3/8/2010 11:41:54 PM
    Event ID: 5ba3b83a27aa4b3cb857d321433e4f04
    Event sequence: 2
    Event occurrence: 1
    Event detail code: 0
     
    Application information:
        Application domain: /LM/W3SVC/1/ROOT-3-129125653136727092
        Trust level: Full
        Application Virtual Path: /
        Application Path: C:\inetpub\wwwroot\
        Machine name: J3FFREY-PC
     
    Process information:
        Process ID: 2432
        Process name: w3wp.exe
        Account name: NT AUTHORITY\NETWORK SERVICE
     
    Exception information:
        Exception type: ConfigurationErrorsException
        Exception message: It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level.  This error can be caused by a virtual directory not being configured as an application in IIS. (C:\inetpub\wwwroot\OES\web.config line 46)
     
    Request information:
        Request URL: http://localhost/oes/default.aspx
        Request path: /oes/default.aspx
        User host address: ::1
        User: 
        Is authenticated: False
        Authentication Type: 
        Thread account name: NT AUTHORITY\NETWORK SERVICE
     
    Thread information:
        Thread ID: 5
        Thread account name: NT AUTHORITY\NETWORK SERVICE
        Is impersonating: False
        Stack trace:    at System.Configuration.ConfigurationSchemaErrors.ThrowIfErrors(Boolean ignoreLocal)
       at System.Configuration.BaseConfigurationRecord.ThrowIfParseErrors(ConfigurationSchemaErrors schemaErrors)
       at System.Configuration.BaseConfigurationRecord.GetSectionRecursive(String configKey, Boolean getLkg, Boolean checkPermission, Boolean getRuntimeObject, Boolean requestIsHere, Object& result, Object& resultRuntimeObject)
       at System.Configuration.BaseConfigurationRecord.GetSection(String configKey, Boolean getLkg, Boolean checkPermission)
       at System.Configuration.BaseConfigurationRecord.GetSection(String configKey)
       at System.Web.Configuration.RuntimeConfig.GetSectionObject(String sectionName)
       at System.Web.Configuration.RuntimeConfig.GetSection(String sectionName, Type type, ResultsIndex index)
       at System.Web.Configuration.RuntimeConfig.get_Identity()
       at System.Web.HttpContext.SetImpersonationEnabled()
       at System.Web.HttpApplication.AssignContext(HttpContext context)
       at System.Web.HttpRuntime.ProcessRequestNotificationPrivate(IIS7WorkerRequest wr, HttpContext context) 

    Monday, March 8, 2010 6:29 AM
  • Monday, March 8, 2010 6:53 AM
  • Monday, March 8, 2010 6:56 AM
  • User1250812075 posted

    Thanks for the reply but i am facing the problem while running my application in built in web server in visual studio 2008.

    Tuesday, March 9, 2010 6:30 AM
  • User-1011786642 posted

    What is the url displayed in the browser when it throws the error?

    If it is something like http://localhost/oes/default.aspx - it is IIS website

    If it has a port number like http://localhost:6413/oes/default.aspx - then you are definitely using the built-in webserver.

    I'm asking you this because I saw that the url in the event log which you pasted is "http://localhost/oes/default.aspx".  This means the request goes to IIS.

    You can check the "Start options" when you right click - "Property Pages" on the website in VS solution explorer.  

     

    Regards,

    Night_dog

    Tuesday, March 9, 2010 6:52 AM
  • User1250812075 posted

    Thank you very much for your reply.

    Actually I had two problems one with the IIS and the other with the builtin asp.net development server in visual studio. I have solved the problem off IIS using your given links but the second problem still persists. The log was created IIS. 

    I still get the "page cannot be displayed" error when i browse my application using development server (builtin) in visual studio. 


    Best regards,


    Wednesday, March 10, 2010 8:12 AM
  • User-37275327 posted

    Did you try hosting in a virtual server? According the error description, it is saying that problem with configuration. Are you sure that all setting in IIS are correct?

    if not hosted on IIS you can check start up form from the solution explorer. Try changing the startup form by right clicking and set as startup.


    Wednesday, March 10, 2010 8:47 AM
  • User1360813390 posted

    This is why I use Chrome!! It is so much simpler and hardly has any problems!!

    Tuesday, March 16, 2010 2:02 PM
  • User-1011786642 posted

    hollypatterns, this has nothing to do with the browser type.

    Hunzian, if you made it work in iis you can setup the website to use this url in Visual studio:

    Right click on the site, choose Property Pages, then select Start options. In Server section select Use custom server and for Base URL type your site for example: http://localhost/oes/

     

    Regards,
    Night_dog

    Thursday, March 18, 2010 10:53 AM