locked
Unable to activate my subscription, JS error RRS feed

  • Question

  • I'm trying to activate my subscription through https://msdn.microsoft.com/subscriptions/add/default.aspx but after clicking "Next" the License Notice and Default Agreement section pops up then an "Uncaught SyntaxError: Unexpected Token }" error is thrown. If I agree to the terms and click "Accept" the page refreshes but nothing is done.

    It's occurring due to an invalid eval statement when calling a "success" handler in ActivateSubscription.js.

    Until this bug is fixed, I can't activate my account and I need to so I can continue to use VS 2013. Is there a way to get my account activated while I wait for this fix?

    • Edited by MCluck90 Monday, April 7, 2014 8:30 PM Removing extra lines
    Monday, April 7, 2014 8:29 PM

Answers

  • Hey MCluck90,

    I just replied to your site feedback.  check your inbox for a mail from sbpfdbk.  

    Long story short is we found the problem and we think we've fixed it, so let us know if you're still seeing issues.

    Thanks,
    Mike


    MSDN and TechNet Subscriptions Support

    • Proposed as answer by Mike Kinsman Wednesday, April 9, 2014 4:12 PM
    • Marked as answer by MCluck90 Wednesday, April 9, 2014 7:01 PM
    Wednesday, April 9, 2014 4:12 PM

All replies

  • MCluck90,

    can you reach out to me via site feedback?  We've gotten a few reports of this over the past 24 hours and we need to investigate quickly.  If you can contact me via MSDN Subscriptions Site Feedback I think that would be the best.

    Visit http://msdn.microsoft.com/subscriptions and click 'site feedback' at the very bottom.

    Reference this thread in the forum, and please include your Subscriber ID and your microsoft account email address you're attemtping to use in the forum. this will put an email in my inbox and I'll be able to work with you directly and where its safe to share that info.

    Thanks,
    Mike


    MSDN and TechNet Subscriptions Support

    Tuesday, April 8, 2014 4:47 PM
  • Hey MCluck90,

    I just replied to your site feedback.  check your inbox for a mail from sbpfdbk.  

    Long story short is we found the problem and we think we've fixed it, so let us know if you're still seeing issues.

    Thanks,
    Mike


    MSDN and TechNet Subscriptions Support

    • Proposed as answer by Mike Kinsman Wednesday, April 9, 2014 4:12 PM
    • Marked as answer by MCluck90 Wednesday, April 9, 2014 7:01 PM
    Wednesday, April 9, 2014 4:12 PM
  • It worked. Thanks!
    Wednesday, April 9, 2014 7:01 PM