none
Azure AD Connect, ADSyncBootstrap service fails to start event id 0

    Question

  • Hi,

    we tried to upgrade from dirsync to ad connect. Installation fails because ADSyncBootstrap service fails to start. Event id 0 is logged with the message:

    <style type="text/css">p.p1 {margin: 0.0px 0.0px 0.0px 0.0px; font: 9.0px Helvetica} </style>

    <style type="text/css">p.p1 {margin: 0.0px 0.0px 0.0px 0.0px; font: 14.0px Helvetica; color: #454545} </style>

    Service cannot be started. System.ServiceModel.CommunicationObjectFaultedException: The communication object, System.ServiceModel.ServiceHost, cannot be used for communication because it is in the Faulted state.

       at System.ServiceModel.Channels.CommunicationObject.Close(TimeSpan timeout)

       at Microsoft.Azure.ActiveDirectory.ADSyncBootstrap.ADSyncBootstrap.OnStart(String[] args)

       at System.ServiceProcess.ServiceBase.ServiceQueuedMainCallback(Object state)

    Any ideas? 

    Monday, May 1, 2017 8:10 PM

Answers

  • Hi,

    in our case Sophos Central AD Sync caused the problem. By temporarily stopping the Sophos sync service we were able to install ad connect.

    • Marked as answer by Kim K.1 Tuesday, August 1, 2017 10:38 AM
    Tuesday, August 1, 2017 10:38 AM

All replies

  • The query needs a further deeper dive technically. We would request you to create a Technical Support case and provide all the log files under the “c:\programdata\aadconnect” folder.
    And, we would request you to provide the other useful information for the support case would be: 
    1)which version of Windows OS is being used? 
    2)Is this being installed on a Domain Controller? 
    3)Are there any custom Group Policies being applied?
    Tuesday, May 2, 2017 4:36 PM
    Moderator
  • I have this exact same issue... I have validated that the AAD_.... account has access to "allow log on locally", "log on as a service", "log on as a batch job".. yet no matter how many times I reinstall or rerun the install it will not complete, with the same error:

    In the log for the install it's failing 3 times to start the new service: "StartService failed to start service (ADSync)"

    In addition if you look at the windows event logs the coordinating event for that logged errors is:

    Source: ADSyncBootstrap

    EventID: 0

    Service cannot be started. System.ServiceModel.CommunicationObjectFaultedException: The communication object, System.ServiceModel.ServiceHost, cannot be used for communication because it is in the Faulted state. at System.ServiceModel.Channels.CommunicationObject.Close(TimeSpan timeout) at Microsoft.Azure.ActiveDirectory.ADSyncBootstrap.ADSyncBootstrap.OnStart(String[] args) at System.ServiceProcess.ServiceBase.ServiceQueuedMainCallback(Object state)

    Monday, July 31, 2017 1:52 PM
  • Hi,

    in our case Sophos Central AD Sync caused the problem. By temporarily stopping the Sophos sync service we were able to install ad connect.

    • Marked as answer by Kim K.1 Tuesday, August 1, 2017 10:38 AM
    Tuesday, August 1, 2017 10:38 AM
  • THANKS!!! This was my problem as well as we have Sophos. As you said I disabled that service (Sophos Central AD Sync Utility), uninstalled Azure AD Connect, and reinstalled it and it worked great.
    Tuesday, August 1, 2017 5:37 PM
  • Same issue here with the Sophos Central AD Sync service.

    Thank you for the post. Saved me a lot of time.

    Monday, April 30, 2018 10:32 PM
  • Thank you ! :) Same problem here.
    Monday, June 4, 2018 3:26 AM