locked
network share RRS feed

  • Question

  • [pi]: PS C:\> net share USB=E:\ /GRANT:everyone,FULL /REMARK:"USB"
    net : The syntax of this command is:
        + CategoryInfo          : NotSpecified: (The syntax of this command is::String) [], RemoteException
        + FullyQualifiedErrorId : NativeCommandError

    NET SHARE
    sharename
              sharename=drive:path [/GRANT:user,[READ | CHANGE | FULL]]
                                   [/USERS:number | /UNLIMITED]
                                   [/REMARK:"text"]
                                   [/CACHE:Manual | Documents| Programs | BranchCache | None]
              sharename [/USERS:number | /UNLIMITED]
                        [/REMARK:"text"]
                        [/CACHE:Manual | Documents | Programs | BranchCache | None]
              {sharename | devicename | drive:path} /DELETE
              sharename \\computername /DELETE

    it would work without the grant option but i need to set grant

    is this a bug?

    Friday, January 15, 2016 4:28 PM

Answers

All replies

  • I created a network share using:

    net share Software=E:\Software /remark:"Software Images"

    and it worked. Displaying the share shows that Everyone has READ permission on it.

    >net share Software
    Share name        Software
    Path              E:\Software
    Remark
    Maximum users     No limit
    Users
    Caching           Manual caching of documents
    Permission        Everyone, READ
    
    The command completed successfully.
    

    However, I can't browse to the network share. It shows up in the list of shares, but when I try to connect to it, I get a connection error 0x80070035.

    Any ideas?

    Tuesday, January 19, 2016 4:01 PM
  • Hi Adaptive,

    0x80070035 says path not found but likely you are hitting a firewall trust issue with an insecure share.  The answer for a standard PC setup is here: http://www.techsupportforum.com/forums/f31/solved-error-code-0x80070035-network-path-not-found-175665.html

    Is the IP address of your device registered with your firewall?

    NOTE: There are two doc sfor file sharing on Windows IoT Core:

    Sincerely,

    IoTGirl

    Tuesday, January 19, 2016 10:55 PM
  • Hi IoTGirl,

    Thank you so much for your response. It turns out I get the error when I try to browse the network share through the computer name of the RPi on one machine. On another machine, I can browse the network share through both the computer name as well as the IP.

    Much appreciated.

    Thursday, January 21, 2016 3:10 AM
  • Hi Adaptve,

    Were you able to identify what was causing the limitation on the computer that could not access by name?

    Sincerely,

    IoTGirl

    Thursday, January 21, 2016 5:39 PM
  • as i have opened that issue it would be nice if you could answer my question!

    thank you

    Thursday, January 21, 2016 5:56 PM
  • Hi Cyberh0me,

    In my first response I provided links to the two file sharing samples. Did you explore those? They should cover most scenarios and therefore help you address your issue.  If they do not cover yours, can you please rephrase your question? From your original post there is no clear ask. You state "it would work without the grant option but I need to set grant".  Why is you needing to set a grant for your scenario a problem?  Unfortunately, I have no answer for this but it does not sound like a bug to me.

    Sincerely,

    IoTGirl

    PS: For bugs at Microsoft we use a template to help make sure all information is gathered to understand the problem. It is something like this:

    PLATFORM Details: Please document all hardware and software used in the reproduction of your issue

    SET UP: Please provide all relevant details to set up the environment to reproduce the issue

    REPRODUCTION Steps: Please provide all steps for someone else to recreate your issue

    RESULTS: Expected result vs actual result and explain why you had the expectation. 

    Getting the above data helps ensure all of the information to understand an issue is present

    Thursday, January 21, 2016 6:12 PM
  • let me rephrase the issue...

    connect to your iot device with powershell and execute the following command to create a network share with grant permissions

    net share USB=E:\ /GRANT:everyone,FULL /REMARK:"USB"

    the expected output of this command would be something like success or smiliar BUT the command produce this output:

    net : The syntax of this command is:
        + CategoryInfo          : NotSpecified: (The syntax of this command is::String) [], RemoteException
        + FullyQualifiedErrorId : NativeCommandError

    NET SHARE
    sharename
              sharename=drive:path [/GRANT:user,[READ | CHANGE | FULL]]
                                   [/USERS:number | /UNLIMITED]
                                   [/REMARK:"text"]
                                   [/CACHE:Manual | Documents| Programs | BranchCache | None]
              sharename [/USERS:number | /UNLIMITED]
                        [/REMARK:"text"]
                        [/CACHE:Manual | Documents | Programs | BranchCache | None]
              {sharename | devicename | drive:path} /DELETE
              sharename \\computername /DELETE

    QUESTION: what on the command net share USB=E:\ /GRANT:everyone,FULL /REMARK:"USB" is wrong?

    Thursday, January 21, 2016 6:21 PM
  • Hi cyberh0me,

    Have you tried the solution given at https://social.msdn.microsoft.com/Forums/en-US/8ea7427c-1430-41de-ab91-f744bb71833b/smb-share-and-granting-permissions?forum=WindowsIoT

    net share e$=e: /GRANT:EVERYONE`,CHANGE /REMARK:"USB Drive"

    Sincerely,

    IoTGirl

    Thursday, January 21, 2016 6:47 PM
  • net share usb=e: /GRANT:EVERYONE`,READ /REMARK:"USB Drive"

    worked for me, thank you very much so sharing is basically working on windows iot devices even if there is a small bug in the net share command syntax help because i miss the important ` char that made the difference....

    [/GRANT:user,[READ | CHANGE | FULL]]


    Thursday, January 21, 2016 7:16 PM
  • Hi cyberh0me,

    Great news that your share is now working! Once you provided more detail I was able to search for other threads with similar questions and found the one that solved your problem.

    As to your concern about the character and documentation, I have brought both threads to the attention of the Windows IoT Team.

    Sincerely,

    IoTGirl

    Thursday, January 21, 2016 9:53 PM
  • unfortunately i have again issues to access a network share :-(
    after reinstall of the last #14366 i have created a network share (to root folder of a usb connected hd) and was able to browse into subfolders

    few days later the network share only worked for the root folder and every subfolder raised a access denied...
    so i deleted the network share and tried to create it again but for whatever reason the result is now

    net share test=e: /GRANT:EVERYONE`,CHANGE /REMARK:"USB Drive"
    System error 1332 has occurred.

    No mapping between account names and security IDs was done.

    edit:
    tried net share usb=e: and have again a working share with access to subfolders?

    Wednesday, July 6, 2016 11:19 PM
  • Hi Cyberh0me,

    Can you give me a ball park on when this started to fail?  14342, 14366, 14376?

    Sincerely,

    IoTGirl

    Thursday, July 7, 2016 9:28 PM
  • i faced the issue with 14366, have not used 14342

    Thursday, July 7, 2016 9:44 PM