locked
can't detach the VS2010 from w3wp process without stopping it RRS feed

  • Question

  • I can't detach the VS2010 from w3wp process without stopping it. The "detach" menu item is just disabled always: wether the process is breaked or executed. How do I detach from w3wp without stopping the process?
    Wednesday, April 27, 2011 8:48 AM

Answers

  • My test result also shows that if we attach to w3wp.exe process with (Managed 4.0 + Native + T-Sql), the "detach" button is disabled. So it sounds that the behavior is by design, you may try attach with "automatically detect" option.
    Eric Yang [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Friday, May 6, 2011 2:46 AM

All replies

  • Usually, we can detach from a running process by right-clicking the process item (in Processes window), and select Detach Process; You may also use Debug -> Detach All to detach from debuggee processes.

     

    By the way, what debugging type (Managed, Native) you selected when attach to w3wp.exe? could you please attach to another process (e.g. notepad.exe), and then check the Detach Process option, is it disabled?


    Eric Yang [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    • Proposed as answer by eryang Thursday, May 5, 2011 8:07 AM
    • Marked as answer by Bogdan Verbenets Friday, May 6, 2011 5:19 AM
    • Unmarked as answer by Bogdan Verbenets Friday, May 6, 2011 5:19 AM
    Friday, April 29, 2011 3:18 AM
  • Indeed, when I have "native, .net 4.0 and t-sql" options checked, then I can't use the "detach" button, but when I have "automatically detect" option enabled, then this button is enabled. If I attach to w3wp, then I see .net 4.0 and t-sql options enabled, if I attach to notepad.exe, then I see native code enabled. Probably trying to debug both native and .net 4.0 disables the "detach" button.
    Thursday, May 5, 2011 11:48 AM
  • My test result also shows that if we attach to w3wp.exe process with (Managed 4.0 + Native + T-Sql), the "detach" button is disabled. So it sounds that the behavior is by design, you may try attach with "automatically detect" option.
    Eric Yang [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Friday, May 6, 2011 2:46 AM