locked
Crystal report error - Load report failed RRS feed

  • Question

  • User1043883433 posted

    Hi,
     
              i have a project which has a crystal report which is been displayed on a webform.
    It runs perfectly on the development machine, but when i try to put it in prod thru a websetup, i get the following error.
    i have followed all the steps from the crnet_deployment document got from business objects.
    What is the problem?
     

    Server Error in '/Loading' Application.


    Load report failed.

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: CrystalDecisions.CrystalReports.Engine.LoadSaveReportException: Load report failed.

    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.


    Stack Trace:

    [LoadSaveReportException: Load report failed.]
       .F(String 	, EngineExceptionErrorID 
    ) +272
       .B(String , Int32 ) +57
       CrystalDecisions.CrystalReports.Engine.ReportDocument.Load(String reportName, OpenReportMethod openMethod, Int16 parentJob) +1191
       CrystalDecisions.CrystalReports.Engine.ReportClass.Load(String reportName, OpenReportMethod openMethod, Int16 parentJob) +469
       CrystalDecisions.CrystalReports.Engine.ReportDocument.'() +98
       CrystalDecisions.CrystalReports.Engine.ReportDocument.get_Database() +7
       CrystalDecisions.CrystalReports.Engine.ReportDocument.SetDatabaseLogon(String user, String password) +64
       Loading.crview1.Page_Load(Object sender, EventArgs e)
       System.Web.UI.Control.OnLoad(EventArgs e) +67
       System.Web.UI.Control.LoadRecursive() +35
       System.Web.UI.Page.ProcessRequestMain() +750
    

     


    Version Information: Microsoft .NET Framework Version:1.1.4322.2300; ASP.NET Version:1.1.4322.2300

    Tuesday, June 28, 2005 5:54 AM

All replies

  • User600176218 posted
    Usually this means the application cannot find your RPT file, or doesn't have read permissions on the directory where the RPT is stored.
    Tuesday, June 28, 2005 9:30 AM
  • User1043883433 posted
    can u pls describe the steps for making the websetup. also tell me the, which option should i select for build property of the crystal report! 
    Tuesday, June 28, 2005 11:47 PM
  • User600176218 posted
    Did you copy the RPT file to the server?
    Wednesday, June 29, 2005 8:47 AM
  • User1043883433 posted

    Hi,

        Thanks for your interest in solving my problem.

    Let me explain to u the scenario again.

    I created this project on my xp box. the project included a crystal report, i made another websetup project following the crnet_deployment.pdf  i acquired from business objects website.

     the crystal report build property was selected as an embedded

    the websetup when installed on another xp box, installed correctly and the application runs perfectly and the report is displayed
    correctly.

    but when i run the same websetup on our deployment server, which is a win 2003 box, the crystal report page shows the error
    which i displayed in my first post.

    What did i do wrong?

    What has to be done differently to deploy an appn built in an xp box to be deployed to a win2003 box. pls help!

    Thursday, June 30, 2005 2:04 AM
  • User600176218 posted

    This may be a permissions problem then.  On XP, the worker process uses ASPNET user, but on Win2003, it uses NetworkService.  Make sure that NetworkService has the same permissions on the win2003 machine as ASPNET has on your XP machine (probably MODIFY on the webroot directory).

    Thursday, June 30, 2005 8:51 AM
  • User1043883433 posted

    Hi,

     

                 I removed the identity impersonate tag from web.config and the report started working on win2003.

    Impersonation was set to true in web.config. why was this causing a problem i don't know. Do u?

    the tag still remains in same app on my xp box. what was the problem on win2003?

    Thanks for taking time out to help me solve the problem. thanks Richard!

     

     

    Friday, July 1, 2005 12:12 AM
  • User600176218 posted
    My best guess is that you have your application set up to use WindowsAuthentication, and the application was trying to impersonate your credentials, rather than the application user.  You probably did not have the proper permissions on the server, but you do on your XP machine.  You might want to read portions of this guide for more help: http://msdn.microsoft.com/library/default.asp?url=/library/en-us/dnnetsec/html/secnetlpMSDN.asp
    Friday, July 1, 2005 11:02 AM
  • User884007794 posted

    I am tried, just couldnt fix the same problem on my application.

    Any help?

    Thanks,

    Joe

     

    Friday, August 19, 2005 8:52 PM
  • User1043883433 posted
    Hi, Business objects forum really sucks. Yes i have managed to solve the problem. this is just a brief summary about how i went about it: if u are using cr version bundled with vs.net then this is applicable. the report should be a embedded report, look in the properties, it might be content for you. make another project in the solution, which will be a websetup project. So go to this url : http://support.businessobjects.com/communityCS/TechnicalPapers/crnet_deployment.pdf.asp and download the pdf file. Go to page 5 and follow the steps for creating the websetup.
    Monday, August 22, 2005 3:08 AM
  • User-1894709165 posted

    Hi Rjdudley

    1. I am devloping a web site for LAN ,

      When I am devlping crystal report on xp it work fine , After thant i install ASP.NET On Windows 2003 ,

      And i got Same Problem Crystal report give error "Lad page faild"

      In Web.Config file i am giving   <identity impersonate="true"/>

     So Pleas give solution

     bye

    Tuesday, July 31, 2007 1:56 AM
  • User-1894709165 posted

    Hi Rjdudley

    1. I am devloping a web site for LAN ,

      When I am devlping crystal report on xp it work fine , After thant i install ASP.NET On Windows 2003 ,

      And i got Same Problem Crystal report give error "Lad page faild"

      In Web.Config file i am giving   <identity impersonate="true"/>

     So Pleas give solution

     bye

    Tuesday, July 31, 2007 1:57 AM
  • User-1323254895 posted

    None of these answer Visual Studio 2005?

    Friday, October 5, 2007 10:00 AM
  • User-259013653 posted

     The issues are the same in VS 2005. Read the white paper (or the most recent version of it) that is linked a couple of posts up. In short: on your dev box, you have VS2005 installed as well as the .NET framework and the necessary Crystal Reports run-time libraries. You need to install the CR merge-modules on your distribution machine so that it will work there, assuming your issue is similar to the OP.

     

    Pont 

    Friday, October 5, 2007 12:06 PM
  • User-1323254895 posted

    That is just it. I did all of that, it works fine on my dev machine, even when I reference the files on the server.

    The security permissions on the folders are identical and I am using Windows active directory security with roles enabled.

    But one I place the or publish the files to the server and run them, everything works but the Crystal reports page.

    Failed to load comes up.

    I even tried making the project folder on the server a share instead of UNC paths.

    Remapped it, works fine using the server locations on my machine but won't run the Crystal page from the server itself.

    Friday, October 5, 2007 2:34 PM
  • User-259013653 posted

     Hmm, and you're sure that you installed the appropriate merge modules for your installation from here:

    http://support.businessobjects.com/downloads/merge_modules.asp

    onto the distribution box using a valid serial number?  Just to be clear also, the error you're receiving is one that indicates that the file wasn't found or was it that the file was found but couldn't be loaded?

    Friday, October 5, 2007 4:03 PM
  • User1854856562 posted

    Proven solution
    restart your IIS

    or Give write permission to temp folder for iis user, current user

    details

    Wednesday, October 10, 2012 2:50 AM
  • User857650375 posted

    I've same problem.

    Have you got solution for This?

    Thursday, July 13, 2017 4:42 AM
  • User1884246244 posted

    Hi Toanthrax,

    I guess your development machines IIS and your production machine IIS version & .NET version is not the same. This error occurs if VS version & CR version is mismatched. I had same problem with my web-App which was developed using VS2005 and when I tried to install that in Windows 10 with many other error "Load failed" error was there. Then I recompile the entire solution with VS2015 and changed necessary references and then all worked. I refer you to see the following thread:

    https://forums.asp.net/t/2124803.aspx?Crystal+Reports+10+report+Not+working+with+VS2015+Error+Unhandled+exception+at+line+83+0x800a1391+JavaScript+runtime+error+bobj+is+undefined

    Hope this will help.

    Regards

    Tarique Iqbal

    Thursday, July 20, 2017 4:28 AM