locked
default parameter values not updated RRS feed

  • Question

  • For testing purposes, I had placed default values in my report parameters. I deployed the whole suite of reports once and tested them. Then I eliminated the default parameters and redeployed, but the server doesn't pick up the changes. Other changes are updated fine, but for some reason it's hanging on to my default parameter values? Why? Is there a way around this?

    Using RS 2000 Beta 2, btw.

    Monday, October 3, 2005 1:28 PM

Answers

  • Modifying the tables directly is not supported. However, you can see this information in the Parameter column in the Catalog table.

    The original intent was to allow for an admin to change the defaults, prompts, etc. and not have it overwritten by the report developer. We should provide a way to override this behavior.
    Wednesday, October 5, 2005 4:23 AM

All replies

  • Perhaps deleting the reports and recreating them would help?

    I think it is a bug.  RS 2000 is up to SP2 now so you should upgrade...
    Monday, October 3, 2005 7:14 PM
  • Sorry, I meant i'm running SP2, not Beta 2.

    > Perhaps deleting the reports and recreating them would help?
    Yes, that's what I'm doing. Seems stupid, though.

    Monday, October 3, 2005 7:27 PM
  • Which table in the ReportServer database contains the default parameter info?

    Monday, October 3, 2005 7:28 PM
  • Modifying the tables directly is not supported. However, you can see this information in the Parameter column in the Catalog table.

    The original intent was to allow for an admin to change the defaults, prompts, etc. and not have it overwritten by the report developer. We should provide a way to override this behavior.
    Wednesday, October 5, 2005 4:23 AM
  • Sorry, feature, not bug... Smile

    If you are deleting the reports manually, one option would be to use the rs command line tool to delete & republish the reports.
    Wednesday, October 5, 2005 2:11 PM
  • > use the rs command line tool
    Is there a tutorial available on this tool?  RS.exe is asking for a script file to execute, but I have no idea what format it's looking for.
    Thursday, October 6, 2005 3:22 PM
  • I came across the same thing in Reporting Services 2005. However, you can change the parameters using the Report Manager.

    http://<servername>/Reports

    Click "Show Details"

    Click the properties icon in the "Edit" column

    Click the "parameters" tab

    Uncheck or reset the default values here.

    Regards, Jeroen

    Monday, March 27, 2006 9:18 AM