none
'System.DllNotFoundException' occurred in PresentationCore.dll RRS feed

  • Question

  • WinXP sp 3. VisStudio 2008.
    I believe this is a Framework setup question...

    I believe the DllNotFoundException started occuring in my C#/WPF app shortly after 'upgrading' to IE 8.
    The error message in the debugger is:

     A first chance exception of type 'System.DllNotFoundException' occurred in PresentationCore.dll
    A first chance exception of type '<CrtImplementationDetails>.ModuleLoadException' occurred in PresentationCore.dll
    A first chance exception of type 'System.TypeInitializationException' occurred in mscorlib.dll
    An unhandled exception of type 'System.TypeInitializationException' occurred in mscorlib.dll
    Additional information: The type initializer for '<Module>' threw an exception.
    'AccuStat.vshost.exe' (Managed): Loaded 'C:\WINDOWS\assembly\GAC_MSIL\System.Configuration\2.0.0.0__b03f5f7f11d50a3a\System.Configuration.dll'
    The thread 0xe4 has exited with code 0 (0x0).
    The program '[672] AccuStat.vshost.exe: Managed' has exited with code -532459699 (0xe0434f4d).


    depends.exe reports that ieshims.dll and wer.dll can't be found.
    When I try to re-install .Net Framework 3.5 sp 1, (http://www.microsoft.com/downloads/thankyou.aspx?familyId=ab99342f-5d1a-413d-8319-81da479ab0d7&displayLang=en) the install ends with "Setup Error", no other information.

    Install logs are in http://cid-ee2afabf97e0633b.skydrive.live.com/browse.aspx/DotNetLogs.

    Thanks for any help on straightening out this mess.

    UPDATE:
    When I run Microsoft Update, this fails:
    Microsoft .NET Framework 3.5 Service Pack 1 and .NET Framework 3.5 Family Update for .NET versions 2.0 through 3.5 (KB951847) x86
    "No products found to patch".

    UPDATE 2:  Trying to run the .Net 3.5 sp 1 full installer (dotnetfx35.exe, 232 mb), get this error:
    [06/05/09,15:18:56] XPSEPSC Installer: [2] Error code 1603 for this component means "Fatal error during installation.
    
    
    
    "
    
    
    
    [06/05/09,15:18:56] XPSEPSC Installer: [2] Setup Failed on component XPSEPSC Installer
    Short of reinstalling WinXP, how can I straighten out this mess?

    • Edited by Number8 Friday, June 5, 2009 8:10 PM
    Friday, June 5, 2009 6:43 PM

All replies

  • Hi,

    I just had a clean VPC with Windows XP SP3 then installed .NET Framework 3.5 SP1 then IE8. Everything just worked as normal. The IEShims.dll doesn't exist either (it is suppose to be in the Program Files\Internet Explorer), only a DLL called XPShims.dll.

    You can try use the Process Monitor to find out which exact module is requesting for this file.

    And can you create a new empty WPF application to see if the app has the same problem?

    If you really want to re-install the .NET Framework:

    Try remove .NET Framework 3.5 / 3.0 / 2.0 from Add/Remove Programs in Control Panel. Also consider use the .NET Framework Cleanup Tool to remove them completely.

    Then re-install .NET Framework 3.5 SP1. See if that works.

    If not, use the setup log collect tool to get the log files packed and upload to SkyDrive, I'll take a look.

    Thanks,

    Jie
    This posting is provided "AS IS" with no warranties, and confers no rights.
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Send us any feedback you have about the help from MSFT at fbmsdn@microsoft.com.

    The CodeFx Project
    My Blog (CHS)
    Monday, June 8, 2009 5:53 AM
    Moderator