locked
How can I get the full list of encodings on Visual Studio 2013 ? RRS feed

  • Question

  • After upgrading to Windows 10, VS2013 no longer shows the full list of encodings on the "Advanced save options" dialog on the "File" menu.

    I need the UTF-8 encoding without signature (to keep accented characters in strings on source code).
    It is a Windows 10 bug or there is some fix for that ?

     
    Friday, August 21, 2015 7:43 PM

Answers

  • I think I found a solution: installing the us english language pack solved my problem. I just installed it, but i'm still using brazilian portuguese as default language.
    • Proposed as answer by Shu 2017 Wednesday, August 26, 2015 8:16 AM
    • Marked as answer by Shu 2017 Monday, August 31, 2015 12:45 PM
    Saturday, August 22, 2015 12:31 AM

All replies

  • Hmm, I have both VS2013 and VS2015 installed on Win10 and neither of them show this issue, they both display the usual encoding list that includes UTF-8 without signature.

    Try a Visual Studio repair perhaps?

    Friday, August 21, 2015 8:21 PM
  • I think I found a solution: installing the us english language pack solved my problem. I just installed it, but i'm still using brazilian portuguese as default language.
    • Proposed as answer by Shu 2017 Wednesday, August 26, 2015 8:16 AM
    • Marked as answer by Shu 2017 Monday, August 31, 2015 12:45 PM
    Saturday, August 22, 2015 12:31 AM
  • On 21/08/2015 21:43, emersonfxbx wrote:

    After upgrading to Windows 10, VS2013 no longer shows the full list of encodings on the "Advanced save options" dialog on the "File" menu.

    <https://social.msdn.microsoft.com/Forums/getfile/711541>

    I need the UTF-8 encoding without signature (to keep accented characters in strings on source code).

    Independently from the fix, I'd suggest against using accented characters in string literals in source code. Storing localized strings in resources instead of directly in source code could be a better approach.

    My 2 cents,
    Giovanni

    Monday, August 24, 2015 10:02 AM