locked
how to fix problems connecting to kinect, or to simulated kinect? RRS feed

  • Question

  • Hi I am currently doing a project that is very similar to the TURTLEBOT and I'm currently having problems trying to use the kinect camera or the simulated kinect in VPL, I always get an error that is shown below. I have already checked that the kinect camera is working by running the samples located in the SDK for the kinect. but no matter what I do including using the VPL or running the DDS node I cannot use or connect to the camera.

    The information I need is data related to color, since I am trying to program the iRobot create to follow a line using the Kinect sensor.

    I am new to these programs and may have missed a few things, can someone please give me a solution troubleshoot.

    I found this program in the forum and tried running it, yet it gave me this error.

    this is just a simple program to tilt the camera, yet I still get the same error. 

    can someone please tell me what I am doing wrong. Your feedback on this matter would be much appreciated. Thank you

    Sunday, April 1, 2012 11:00 PM

Answers

All replies

  • I found my problem, after reading a few more threads in the forum, I found out that RDS4 beta 2  does not work well with the kinect. 

    After installing the latest version, I can now successfully connect to the kinect.

    But my other problem is now how do I get data with respect to colour, which data tyoe do I use?


    joseph

    Monday, April 2, 2012 11:36 PM
  • Correct - RDS 4 Beta 2 only works with Kinect Beta 2.  RDS 4 (final release) works with Kinect v1.0 (final release).

    One of the other devs will help you shortly with your color questions (I don't have the code in front of me...)

    Tuesday, April 3, 2012 12:15 AM
    Moderator
  • Look at the KinectUISample. Kinect Service outputs KinectRawData, which has RawColorFrameData and RawColorFrameInfo datatype which should give you the color data.

    Tuesday, April 3, 2012 1:20 AM
    Moderator
  • Thank you ver much for the reply, but I was wondering if it was possible to use VPL to do some sort of blob tracking with the kinect, for I am not to familiar with C#. Is there anyway to replace the cliff sensor in the iRobot line following sample with a kinect sensor?

    joseph

    Tuesday, April 3, 2012 1:27 AM
  • Wednesday, April 4, 2012 8:12 PM
    Moderator
  • Yes, that would be fine.

    Thank you again.


    joseph

    Wednesday, April 4, 2012 11:48 PM
  • can u please tell me which simulator for kinect you are using?

    Sunday, August 16, 2015 7:27 PM