locked
New ContentPage now showing in New Item RRS feed

All replies

  • User180523 posted

    Not sure what you think you're announcing. What is it you think is new? ContentPage has been in NewItem forever. How else would you have added a new ContentPage?

    You do realize you're looking at all C# items and not just Xamarin.Forms items, right?

    Tuesday, June 26, 2018 5:58 PM
  • User369473 posted

    @ClintStLaurent said: Not sure what you think you're announcing. What is it you think is new? ContentPage has been in NewItem forever. How else would you have added a new ContentPage?

    You do realize you're looking at all C# items and not just Xamarin.Forms items, right?

    As you are seeing I don;t show Xamarin files , just C# items ??

    Tuesday, June 26, 2018 5:59 PM
  • User180523 posted

    I still don't know what your announcement is supposed to be about.

    New ContentPage now showing in New Item What new ContentPage is now showing?

    Wait... Do you mean NOT showing? Are you asking why you don't see ContentPage when you try to add a new item? Is that your question?

    Tuesday, June 26, 2018 6:40 PM
  • User369473 posted

    @ClintStLaurent said: I still don't know what your announcement is supposed to be about.

    New ContentPage now showing in New Item What new ContentPage is now showing?

    Wait... Do you mean NOT showing? Are you asking why you don't see ContentPage when you try to add a new item? Is that your question?

    Sorry for my bad English , I can't create a XAML file with C# in it , before it was as ContentPage there . Now I can't see any pages. Any solution ?

    Tuesday, June 26, 2018 7:18 PM
  • User180523 posted

    Select the Xamarin.Forms subgroup as shown in my screen shot.

    Tuesday, June 26, 2018 7:21 PM
  • User369473 posted

    I don't have that Xamarin Forms option ?

    Tuesday, June 26, 2018 7:22 PM
  • User180523 posted

    Then you didn't install the "Cross-Platforms Apps (Xamarin)" workload when you installed Visual Studio. Re-run the Visual Studio installer and install that workload.

    Tuesday, June 26, 2018 7:25 PM
  • User369473 posted

    @ClintStLaurent said: Then you didn't install the "Cross-Platforms Apps (Xamarin)" workload when you installed Visual Studio. Re-run the Visual Studio installer and install that workload.

    I unistalled Mobile Development with Xamarin Installer , than I re -installed , still the same thing

    Tuesday, June 26, 2018 7:29 PM
  • User180523 posted

    Not sure what to tell you. You're installation is is flaky and that's why the option isn't showing. Personally I'd uninstall all of Visual Studio - reboot. Install Visual Studio with EVERYTHING. Every workload, every option, every feature, nothing left unchecked. That's how I always install Visual Studio: Everything including the kitchen sink.

    Tuesday, June 26, 2018 7:38 PM