locked
multiple issues with WCF DataServices October 2011 CTP RRS feed

  • Question

  • Hi,

    I am having multiple problems with my custom un-typed DataService Provider after installing WCF Data Services October 2011 CTP.

    First problem: For each client query request to my service I am getting 2 calls to my CustomQuery.GetEnumerator(), where CustomQuery implements IOrderedQueryable<T> instead of one.

    Second problem: Data Services seem to be caching the first client request. Any subsequent client request is replaced with the very first one before it reaches my service.

    Example: Once my service is started, when I open browser and type some query request (http://<hostName>:address/Enties()/?$filter=Name eq 'bob'), this first query request reaches my service normally and the service sends back the query result.  After that if I try to construct different query or even ask for metadata document (http://<hostName>:address/$metadata), my service is getting called with the first request instead of a new one. And this behavior will stay until I restart the service.

    Third problem: Visual studio 2010 SP1 seems to disappear from my machine after I installed CTP (VS's help->about is not showing it, showing RTMRel instead of SP1 Rel). It's also not showing under add/remove programs. I tried to re-install SP1, got the error: "KB2182621 does not apply, or is blocked by another condition on your computer". Tried to uninstall CTP and re-install VS SP1 - the same error.

    The OS version is Windows 7.

    Any help will be greatly appreciated, thanks!

    Elena

     

     

    Friday, November 11, 2011 8:45 PM