none
997 Error - document type is not recognized RRS feed

  • Question

  • Everytime BizTalk picks up an 837 transaction, I get the following error:

    Error encountered: ERROR (39), docnr 10090 :

    The document type is not recognized. Contact the sender.RootLabel: [X12_4010_997], PublicId: [], SystemId: [http://schemas.wpc-edi.com/X12/ISOMORPH/HIPAA/4010A1/TS997A1], (msgnr:0 segnr:0)(line:0 pos:44 filepos:44)

    Function:

    DetermineFormat

    Is there a way to handle the 997, or prevent BTS from creating it?

    Wednesday, April 8, 2009 3:37 PM

All replies

  • Yes it is a party configuration. In the X12 properties -> Party as Interchange Sender -> ACK Generation and Validation Settings there is a Generate 997 check mark box, uncheck it.
    Eric Stott [http://blog.biztalk-info.com] - Mark as Answer if this reply does.
    Wednesday, April 8, 2009 4:33 PM
  • Hi,
        Is this error is in 997. The document is coming out or not?
    If you need to send 997 ACK to your partner then you should not prevent BTS from creating it.

    Thanks
    Gyan
    Wednesday, April 8, 2009 4:47 PM
  • In your EDI Application you should see the 997 schema, do you see it there?
    Eric Stott [http://blog.biztalk-info.com] - Mark as Answer if this reply does.
    Wednesday, April 8, 2009 6:59 PM
  • Thanks for your replies.  I'll answer you questions in the order they were posted:
    Where do I find X12 properties?
    We are the sending and receiving party so no need to generate the ack.
    I do not see the 997 schema
    Thursday, April 9, 2009 5:13 PM
  • You don't see the schema in the EDI Application, or you don't see the EDI Application?
    Eric Stott [http://blog.biztalk-info.com] - Mark as Answer if this reply does.
    Thursday, April 9, 2009 5:28 PM
  • I don't see the schema under the EDI application.
    Thursday, April 9, 2009 10:50 PM
  • I would repair the installation, as it should be installed when you enable EDI in the configuration.
    Eric Stott [http://blog.biztalk-info.com] - Mark as Answer if this reply does.
    Thursday, April 9, 2009 10:52 PM
  • I would rather prevent the 997 from being created since I'm not going to use it.
    Saturday, April 11, 2009 2:46 PM
  • In the party definition of the trading partner in the ACK Generation and Validation you can turn off the creation of the 997
    Eric Stott [http://blog.biztalk-info.com] - Mark as Answer if this reply does.
    Saturday, April 11, 2009 4:43 PM
  • Hi,
        If you are not able to see the 997 schema in the EDI application then installed Biztalk is corrupted. It will be better if you will repair it or configure it again. Otherwise in future you will get many problems.


    Thanks
    Gyan
    Sunday, April 12, 2009 10:08 AM