locked
TFS 2012 automated builds fail for no clear reason RRS feed

  • Question

  • Hello, I run TFS 2012, Visual studio 2012, IIS 7.5.7600.16385, Windows 7 Proffessional 

    I configured a TFS build definition with code coverage unit tests. It is triggered by every check in.
    I have a big build queue, where every change is a simple comment change in the cs files.

    The builds fail majority of the time, with different errors. But sometimes it doesn't fail.

    The solutions do always build if I rebuild the solution(out of tfs)

    The different errors that causes the build to not build(I get only 1 error per failed build definition):

    C:\Builds\3\Voogd\Nightly Builds 3\Sources\Main\Libs\pdf.dll: Unable to read data from the transport connection: De externe host heeft een verbinding verbroken.

    C:\Builds\3\Voogd\Nightly Builds 3\Sources\Main\Libs\NHibernate\NHibernate.dll: Unable to read data from the transport connection: De externe host heeft een verbinding verbroken.

    C:\Builds\2\Voogd\NB\3\Sources\Main\Clients\VVS3\VoertuigData\ReferencedDLLs\VoertuigdataCache.dll: Unable to read data from the transport connection: De externe host heeft een verbinding verbroken.

    C:\Builds\2\Voogd\NB 3\Sources\Dev\Project 3\Libs\NHibernate\FluentNHibernate.dll: Unable to read data from the transport connection: De externe host heeft een verbinding verbroken.

    C:\Builds\2\Voogd\Nightly Builds Project 3\Sources\Dev\Project 3\Libs\VoogdDocumentConverter.dll: Unable to read data from the transport connection: De externe host heeft een verbinding verbroken.

    C:\Builds\2\Voogd\Nightly Builds Project 3\Sources\Dev\Project 3\Services\Berekeningen\Documents\Voogd.Services.Berekeningen_old.ump: Unable to read data from the transport connection: De externe host heeft een verbinding verbroken.

    C:\Builds\2\Voogd\Nightly Builds Project 3\Sources\Dev\Project 3\Libs\wnvrtftopdf.dll: Unable to read data from the transport connection: De externe host heeft een verbinding verbroken.

    C:\Builds\2\Voogd\Nightly Builds Project 3\Sources\Main\Libs\System.Data.SQLite.DLL: The CRC in GZip footer does not match the CRC calculated from the decompressed data.

    When I stop the build I also get a warning:

    The workflow instance accepted a stop request but did not complete within 00:00:29.9983269. This may indicate an AsyncCodeActivity is active that does not support cancellation.

    Monday, September 24, 2012 3:10 PM

Answers

  • I got rid of the problem by installing tfs on an external hyper v machine, with windows server 2008 R2.


    Monday, October 15, 2012 12:54 PM

All replies

  • Hi Visual Studio User,

    Thank you for your post.

    I am trying to involve someone to further look at this issue. There might be some time delay. Appreciate your patience.

    Thank you for your understanding and support.

    Regards,


    Lily Wu [MSFT]
    MSDN Community Support | Feedback to us

    Tuesday, September 25, 2012 6:42 AM
    Moderator
  • Lowering the MinBytesPerSecond  threshold in IIS should give you the relief:

    1.Open the IIS Manager

    2.In the Connections pane, make sure the name of your AT is selected.

    3.In the middle pane (titled “<MachineName> Home”), make sure you are in the “Features View” (bottom) and scroll down to the Management section.

    4.Double-click the “Configuration Editor” icon.

    5.The middle pane should now have the title “Configuration Editor”.  In the Section pull down near the top, expand the system.applicationHost and select “webLimits”.

    6.You should now see a bunch of property value pairs, one of which is named “minBytesPerSecond”.  Its value is most like 240.  You will want to lower this value for the workaround. 

    In general, the lower the threshold is, the lower the chances are that you hit the issue above.  However, you may not want to lower the setting too much because then connections that should be killed by this timer will not be appropriately cleaned up.  Play around with values to see what works best for you.

     

    Are your machines physical or virtual?  If on hyper-V, put all your virtual servers on one virtual switch/network and communicate out to the rest of the real world network via its own dedicated gigabit NIC. 

    http://blogs.technet.com/b/jhoward/archive/2008/06/17/hyper-v-what-are-the-uses-for-different-types-of-virtual-networks.aspx

    Tuesday, September 25, 2012 6:36 PM
  • I changed the MinBytesPerSecond to lower values, but it doesn't help, I am still getting the same errors. The machine I use is physical so I can't use the solution.

    Wednesday, September 26, 2012 10:20 AM
  • Your question requires a more in-depth level of support. Please visit the below link to see the various support options that are available to better meet your needs. http://support.microsoft.com/default.aspx?id=fh;en-us;offerprophone
    Tuesday, October 9, 2012 12:44 AM
  • I got rid of the problem by installing tfs on an external hyper v machine, with windows server 2008 R2.


    Monday, October 15, 2012 12:54 PM