locked
Reportviewer Control Problem is VS2013 RRS feed

  • Question

  • I migrated my VB web application from VS2010 to VS2013. Everything works fine except the Reportviewer control. I get "Error creating control-reportviwer. Failed to create designer 'Microsoft.Reporting.Webforms.Reportviewer.....'  Any suggestions?  Thanks, Jim
    Friday, August 22, 2014 12:48 PM

Answers

All replies

  • Hi Jim,

    >>Error creating control-reportviwer. Failed to create designer 'Microsoft.Reporting.Webforms.Reportviewer.....

    Since you get this issue when you update the app from VS2010 to VS2013, so one possible reason is that it has different version dll file for this kind of app, so you'd better move the old version dll file, and then re-add the new references.

    Reference:

    https://connect.microsoft.com/VisualStudio/feedback/details/782000/designer-error-using-reportviewer-2010-in-visual-studio-2012

    http://forums.asp.net/t/1732350.aspx?How+can+I+load+report+viewer+2010+and+use+it+in+my+visual+studio+2008+project+

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place. <br/> Click <a href="http://support.microsoft.com/common/survey.aspx?showpage=1&scid=sw%3Ben%3B3559&theme=tech"> HERE</a> to participate the survey.

    Monday, August 25, 2014 9:18 AM
  • Hi there,

    I am using VS2013 (community) and have developed a very basic report using the report developer which looks OK. I need to run the report on a web page but I cannot find ReportViewer control in the toolbox. After searching various places I installed VS2012 version of Webform.dll and Winform.dll and added these tools, choose toolbox items, etc but the control still does not appear in the toolbox. I then managed to find a older version of the DLLs and I can see the control in the toolbox. After adding the control on a web page and configuring the datasource etc when I compile I get an error - could not find schema information for the element 'validation'. Can you please assist - how to use ReportViewr in VS2013?

    I am also new to ASP.NET development.

    Thanks.

    Thursday, December 25, 2014 1:21 PM
  • Hi!

    The solution you suggested worked like a dream during the Development.

    however the problem reappeared during deloyment on a remote machine. 

    I have a project which was developed earlier in VB 2008 using Reportviewer.Winforms version 9.00. Have now upgraded the Project to Visual Stuidio 2015. Have reports here using Reportviewer.Winforms version 12.00. Working fine when set reference to new version of Reportviewer in Projects. However having problem when deploying on a remote machine.

    Problem while running any form having Reportviewer. Get error message "Could Not Load File or Assembly Reportviewer.Winforms version 12.00"

    I am copying the entire bin>>Debug>> folder. 

    'Bin' folder has both Microsoft.ReportViewer.Common.dll & Microsoft.ReportViewer.WinForms.dll. 

    Worked fine earlier in VS 2008 with Reportviewer.Winforms version 9.00

    I guess problem can be that remote machines only have version 9 registered. however tried downloading from Microsoft site & even installing .Net 4.6 but to no avail

    Pl assist


    Tuesday, September 29, 2015 10:41 AM