locked
Migrated SQL server, but users cannot login. RRS feed

  • Question

  • Hi all,

    New to MSSQL here. I recently migrated our SQL database to a new server. I was able to copy all the databases and transfer the logins to the new server, but not sure how to grant users access to the databases.

    I am able to connect to the new server using Windows authentication, but other users that also use Windows Authentication can not connect, I get the error:  

    A <g class="gr_ gr_615 gr-alert gr_spell gr_inline_cards gr_disable_anim_appear ContextualSpelling" data-gr-id="615" id="615">network-related</g> or instance-specific error occurred while establishing a connection to SQL server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server) ---> System.ComponentModel.Win32Exception: The network path was not found.

    For other users I created a "New User" under the Databases they need access to, with the same properties they had on the old server,  but that didn't help.

    Are there any guides on what to do after migrating the databases and the logins? 

    Thanks for your help.

     

    Friday, June 9, 2017 1:55 PM

All replies

  • garbled error message...

    Are they specifying servername?   Is TCP enabled or are you actually using Named Pipes?  Is the SQL a default or named instance?


    22 years of database experience, most with SQL Server. Please 'Mark as answered' those posts that helped you.

    Friday, June 9, 2017 2:08 PM
  • After the database migration from one server to another server.

    1) You need to transfer the logins of particular database from server A to Server B

    2) If required need to fix the orphan users

    Please let me know.

    Thanks,

    Satish Kumar.


    Thanks, Satish Kumar. Please mark as this post as answered if my anser helps you to resolves your issue :)

    Wednesday, June 14, 2017 5:03 PM