locked
Not able to create Application Package by using Visual Studio 11 by store option

    Question

  • Hi

    We are creating Application Package using Visual Studio 2011 by option store--> Create App Package... --> Create a package to use locally only.

    Our projects includes Background Task project with output type "WinMD File".

    It gives error "Task 'GenerateAppxPackage' failed. The Device is not ready."

    Please suggest to resolve this issue.

    Thanks

    Ravi Shankar 


    Ravi Shankar- Sr. Software Developer

    • Moved by Matt SmallMicrosoft employee, Moderator Tuesday, May 22, 2012 4:31 PM Store packaging issue (From:Building Metro style apps with C# or VB )
    • Moved by Jesse_F Thursday, May 24, 2012 5:50 PM notified to transfer (From:Windows Store: Publishing Metro Style apps for Windows 8)
    Tuesday, May 22, 2012 12:45 PM

All replies

  • Hello Ravi,

    What type of machine are you using for this? If you are debugging on an ARM device, this is not supported in Visual Studio 2011 Beta. Have a look at the page about running Windows 8 apps on remote machines. If you don't already have it, go to the bottom of the page and you will see a download for the remote debugger.

    Also, are you using the Developer Preview or the Consumer Preview? If you are still using the Developer Preview, have a look at the page about migrating a build app to Consumer Preview. Please provide more details about the issue if you have them. I hope this helps.

    Thanks,

    Jesse

    Tuesday, May 22, 2012 5:40 PM
  • Hi Jesse

    We are using Windows 8 Consumer Preview and device is x64/x86, and not doing debug the project else creating Application Package using Visual Studio 2011 by option store--> Create App Package... --> Create a package to use locally only.

    Our projects includes Background Task project with output type "WinMD File".

    It gives error "Task 'GenerateAppxPackage' failed. The Device is not ready."

    Please suggest to resolve this issue.

    Regards

    Ravi Shankar


    Ravi Shankar- Sr. Software Developer

    Wednesday, May 23, 2012 5:57 AM
  • Have you downloaded the debugging tools from the link I previously provided? The tools will give you specific details on where your app is failing. You may also take a look at your Event Viewer and see if the machine itself it performing correctly. I hope this helps.

    thanks,

    Jesse

    Wednesday, May 23, 2012 2:35 PM
  • Hi Jesse,

    Did you get a chance to upgrade to the Release Preview? If not, please do so and let us know if you run into the same problem.

    Thanks.

    Thursday, June 7, 2012 5:51 PM
  • Hi Ravi shankar, have you found any solution for this? I also got same problem, In my my case the "Output Location" is wrong. by giving a valid output loaction, i am able create package now. i am not sure about your case, but it might be.

    Pallam Madhukar Windows Phone Developer

    Tuesday, September 17, 2013 9:28 AM